Bug 390721 - gnome-scan in updates-testing fails to install because of circular dependency
gnome-scan in updates-testing fails to install because of circular dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 12:29 EST by Luis Villa
Modified: 2014-01-21 18:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 11:46:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Villa 2007-11-19 12:29:55 EST
gnome-scan 0.5.3 depends on gnome-scan 0.4.0, apparently, which as you can
imagine causes conflicts and therefore fails to install. yum transaction below:

[louie@towel ~]$ sudo yum install gnome-scan
Password:

...

Resolving Dependencies
--> Running transaction check
---> Package gnome-scan.i386 0:0.5.3-0.1.20071030svn.fc8 set to be updated
--> Processing Dependency: libgegl-1.0.so.0 for package: gnome-scan
--> Processing Dependency: libgnomescan.so.0 for package: gnome-scan
--> Processing Dependency: libbabl-0.0.so.0 for package: gnome-scan
--> Running transaction check
---> Package babl.i386 0:0.0.15-0.5.20071011svn.fc8 set to be updated
---> Package gegl.i386 0:0.0.13-0.7.20071011svn.fc8 set to be updated
--> Processing Dependency: libIlmImf.so.6 for package: gegl
--> Processing Dependency: libIex.so.6 for package: gegl
--> Processing Dependency: libIlmThread.so.6 for package: gegl
--> Processing Dependency: libImath.so.6 for package: gegl
--> Processing Dependency: libHalf.so.6 for package: gegl
---> Package gnomescan.i386 0:0.4.0.2-1.fc7 set to be updated
--> Running transaction check
---> Package ilmbase.i386 0:1.0.0-3.fc8 set to be updated
---> Package OpenEXR-libs.i386 0:1.6.0-5.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 gnome-scan              i386       0.5.3-0.1.20071030svn.fc8  updates-testing 
 100 k
Installing for dependencies:
 OpenEXR-libs            i386       1.6.0-5.fc8      fedora            250 k
 babl                    i386       0.0.15-0.5.20071011svn.fc8  updates        
   94 k
 gegl                    i386       0.0.13-0.7.20071011svn.fc8  updates        
  392 k
 gnomescan               i386       0.4.0.2-1.fc7    fedora            328 k
 ilmbase                 i386       1.0.0-3.fc8      fedora            118 k

Transaction Summary
=============================================================================
Install      6 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 1.3 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/bin/flegita conflicts between attempted installs of
gnomescan-0.4.0.2-1.fc7.i386 and gnome-scan-0.5.3-0.1.20071030svn.fc8.i386
  file /usr/lib/gimp/2.0/plug-ins/flegita-gimp conflicts between attempted
installs of gnomescan-0.4.0.2-1.fc7.i386 and
gnome-scan-0.5.3-0.1.20071030svn.fc8.i386
Comment 1 Deji Akingunola 2007-11-19 13:29:51 EST
I think this is a yum bug, so re-assigning.
To yum maintainer: gnome-scan is a rename of gnomescan, and also along with
getting renamed, the a gnome-scan-libs has been split out of the main package.
Versioned obsolete and Provides were properly properly put in place for
gnome-scan main package and the gnome-scan-libs subpackage, however yum is still
trying to pick the old gnomescan to satisfy the dependency instead of choosing
gnome-scan-libs.

Luis: You can work around the file conflict in the meantime by running 'sudo yum
install gnome-scan gnome-scan-libs' 
Comment 2 Jeremy Katz 2007-11-19 15:33:21 EST
Interesting... reproduced.  We need to have a check for obsoletes probably in
_requiringFromTransaction before the check based on name length.  
Comment 3 Luis Villa 2007-11-25 16:59:55 EST
I don't think it is, but before filing another bug: is this bug the same reason
I'm currently seeing the following (apparently bogus?) dependency:

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 kernel                  i686       2.6.23.8-62.fc8  updates-testing    16 M
Installing for dependencies:
 kernel                  i586       2.6.23.1-49.fc8  updates            16 M

The i586 package then has file conflicts with the i686 2.6.23.1-49.fc8 kernel
I've already got installed; fun, fun, fun.
Comment 4 Jeremy Katz 2007-11-26 10:56:17 EST
Yeah, it's highly likely to be the same root cause.  mutter, grumble, etc, etc... :)
Comment 5 Luis Villa 2007-11-26 11:01:15 EST
(shrug) better one root bug with multiple impacts than many root bugs. :)
Comment 6 Seth Vidal 2008-03-12 11:46:02 EDT
And we have that obsoletes check now and many many more.

Note You need to log in before you can comment on or make changes to this bug.