Bug 39077 - kernel-2.2.19-7.0.1 & nfs3 unstable
kernel-2.2.19-7.0.1 & nfs3 unstable
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-04 04:19 EDT by Gerald Teschl
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-21 05:57:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2001-05-04 04:19:24 EDT
Description of Problem:
The upgrade to the latest errata kernel 2.2.19-7.0.1 caused a switch to
nfs3,
however, this does not seem to work stable! If the load gets to high the
sever
will go down approx. once per hour: Either the eth intercae will be gone
(can be brought up again from the console), or the kernel will panic.

I disabled nfs v3 on the server and now the server runs stable again since
almost a week.


How Reproducible:
Since this is our main server, I cannot do any furhter testing.


Additional Information:
Hardware: AMD Athlon(tm) Processor 770MHz, Realtek  RTL-8139 (rev 10)
ethernet card
Comment 1 MEGASOFT HACKERS GROUP 2001-05-07 10:35:28 EDT
It's more related to troubles with RTL8139 driver, which have EXPERIMENTAL
status in kernel and very buggy on high-load ( your may go to www.scyld.com -
homepage of Donald Becker (original version of this driver). Also SCYLD host
maillist realtek-bugs - your found many bugreports, like your :)
And bugs with rtl8139 often with NFS (UDP high load). Interface stop respond or
system reboot :) Alternative - use Donald Becker latest rtl8139.c or alternative
driver 8139too (originally developed for 2.4, but then backported to 2.2 and
included with >2.2.18).
But may choise - replace 8139 with more stable netcard(stable driver) ( Intel
EE100 for example).

Sorry, my English very poor :)
Comment 2 Arjan van de Ven 2001-05-07 16:53:54 EDT
It might indeed be 8139 related. Could you try to use the 8139too module
instead?
(just change the modulename in /etc/modules.conf)
Comment 3 Gerald Teschl 2001-05-09 14:48:05 EDT
Thanks for your help. I wasn't aware of the other module. In fact, I changed it
yesterday evening
and there were no problems since. (However, I have not turned nfs v3 on again).
I'll keep you
informed.
Comment 4 Arjan van de Ven 2001-05-21 05:57:12 EDT
I assume that everything is ok, and will close this bug as "Currentrelease".
If you have problems again, please reopen this bug.
Comment 5 Gerald Teschl 2001-05-29 05:26:59 EDT
Yep, the 8139too module seems to wor better, but it is MUCH slower! Anyway,
I'll move to 2.4.

Note You need to log in before you can comment on or make changes to this bug.