Bug 39089 - After installation system hangs at kswapd
After installation system hangs at kswapd
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
: 44830 53112 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-04 08:56 EDT by Dennis J Vought
Modified: 2008-08-01 12:22 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hardware summary (6.03 KB, text/plain)
2001-05-09 21:35 EDT, Dennis J Vought
no flags Details

  None (edit)
Description Dennis J Vought 2001-05-04 08:56:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
I can successfully install 7.0 on my computer. When I install 7.1 and the 
system reboots the last message on the screen is kswapd v1.8.  System is 
then hung and i physically have to power the machine off.

How reproducible:
Always

Steps to Reproduce:
1.install 7.1 on my computer
2.
3.
	

Actual Results:  hangs at message kswapd v 1.8

Expected Results:  continued to boot

Additional info:

Computer configuration
Compaq presario
Cyrix processor
128 meg RAM
2 Seagate 4.0 gig hard disks
video on mother board SIS 5598
56K PCI modem
250 Meg IOMEGA Zip drive
HP 970c Deskjet printer
Comment 1 Brent Fox 2001-05-04 11:18:05 EDT
Try booting with 'linux ide=nodma'.  Does this help?
Comment 2 Dennis J Vought 2001-05-07 07:44:40 EDT
Tried your suggestion of booting with linux ide=nodma
Still hangs at kswapd
Comment 3 Brent Fox 2001-05-07 16:09:04 EDT
Are there any error messages on VC3 and VC4?
Comment 4 Dennis J Vought 2001-05-08 08:26:37 EDT
when system hangs I can't switch screen to check to see the messages on
VC 3 & Vc 4
Comment 5 Brent Fox 2001-05-08 15:00:38 EDT
Have you checked the md5sums of the iso's to make sure that nothing got
corrupted during the download?
Comment 6 Dennis J Vought 2001-05-08 15:57:19 EDT
I didn't download this version I bought the cd's from Redhat.  I can install 
this version to a different Compaq computer (Deskpro).
Comment 7 Brent Fox 2001-05-08 17:42:34 EDT
Alan, have you seen any behavior like this on Cyrix machines before?
Comment 8 Alan Cox 2001-05-08 18:46:35 EDT
Not specifically. A hardware summary of the machine would be a really nice help.
Also whose BIOS and what revision
Comment 9 Dennis J Vought 2001-05-09 21:35:14 EDT
Created attachment 17966 [details]
hardware summary
Comment 10 Alan Cox 2001-05-10 06:30:51 EDT
Boot with mem=64Mb and tell me if that does the same. Also when you have to
physically power off (Im assuming the box is ATX) can you just hit the reset
button or do you have to actually hold the power button in for about 8-10
seconds ?

Brent: I have seen a couple of other SiS5598 reports and I have a list of other
interesting features of that board. However the known hardware quirks dont
explain this bug report. The main thing that is odd about the 5598 is that the
video is on board driven from main memory - however since our bug reporter is
getting to the kswapd message it means that

o	We have done the PCI setup and survived
o	We have done the video setup and survived
o	We have done disk I/O (partitions) and survived

Is there a 5598 board left in the lab (mine died ages ago) ?
Comment 11 Dennis J Vought 2001-05-10 08:30:36 EDT
In response to your requests
Boot with mem=64Mb still hangs at kswapd
I have to hold the power button in for a 8-10 seconds
Comment 12 Brent Fox 2001-05-10 15:58:21 EDT
Dave, do we have any motherboards with SiS5598 onboard in the test lab?
Comment 13 David Lawrence 2001-05-10 23:04:52 EDT
Do you know what particular brands/models of PC come with these motherboards in
them by default? I do not have a motherboard with that specific chip on it but
we may have a machine in the lab that we can borrow long enough to test this if
I have an idea on what to look for.
Comment 14 Dennis J Vought 2001-05-11 07:20:04 EDT
In response to your question
Compaq model 2266
Comment 15 Need Real Name 2001-06-20 15:12:05 EDT
I have the same problem. I am using Compaq Presario 2286 with 64 Megs of memory
After installation of Red Hat Version 7.1 system hangs at kswapd.
The last message I see "Starting kswapd v1.8", after that system hangs.
Comment 16 Need Real Name 2001-06-25 19:00:29 EDT
Could you tell me the status of fixing this bug? I purchased Red Hat 7.1 
version of Linux, and I cannot use it because of the same bug. PLEASE, inform 
me how to proceed.

If you need any additional information, I will be happy to provide it.
Comment 17 Alan Cox 2001-06-25 20:29:37 EDT
The answer right now is that I have no other similar bug reports. It could be
many things - the chipset, a BIOS interaction, a Red Hat kernel bug and more.

I can't give you a date for fixing this one. I really wish I could. We have a
satisfaction guarantee on our products. Given the situation you are in please
contact customer service and ask for a refund. I really wish I could do better
than this option...

If they need more info cite the bug number and <alan@redhat.com> .

Alan

Comment 18 Andre Robatino 2001-06-28 16:55:28 EDT
  See bug 39191 for a similar problem with kswapd on slightly different hardware
with a Cyrix chip.  I just did a capture of the boot messages via the serial
console which allowed me to see that kswapd fails (after this, there is a huge
number of call trace numbers which made it impossible before to see what was
happening).
Comment 19 Need Real Name 2001-07-03 07:19:48 EDT
Hey,
Is this a problem, with all Compaq Presarios with a cyrix. Even I have the same 
nagging problem. It shows "Starting kswapd v1.8" and just stops. By the way 
mine is a COmpaq PResario 2262 This ones got a SiS5597/5598 board. ANd the 
problem is only on kernel 2.4. RedHat 6.2 and 7.0 (using the pre 2.4 ie 2.2.x 
kernels) were never a problem. ALso on 6.2 I tried to compile and run 2.4.2. It 
was the same problem again.
Peter
Comment 20 Bill Soudan 2001-09-29 00:49:37 EDT
I've also run into this problem.  Was just rebooting my 7.1 server which had 
been running fine, and I hit this problem.  Totally different hardware.  I was 
baffled, and was just about to post a 'me too' here too, until I remembered 
that I had the problem when I installed 7.1 and I figured out a workaround...

Turns out I like to use GRUB instead of LILO.  For some reason, booting with 
GRUB like so:

grub> root (hd0,0)
grub> kernel /boot/vmlinuz-2.4.2-2 root=/dev/hda3
grub> boot

causes the kswapd initialization to hang.  However, if I boot the machine by 
chainloading lilo, which I installed on the first sector of the boot partition 
during install:

grub> root (hd0,0)
grub> chainloader +1
grub> boot

then select 'linux' from the lilo menu, all works well.  

I don't know if that's the same cause of bigdog's booting problems, but maybe 
it will at least help in tracking down what's really causing it?

I'll be happy to provide more info to help troubleshoot.
Comment 21 Alan Cox 2001-09-29 04:35:52 EDT
Old versions of grub won't correctly boot a 2.4 kernel
Comment 22 Richard Gate 2001-10-21 11:55:26 EDT
I am having exactly the same problem booting the CD to start an upgrade on a 
Packard Bell Spirit which is running 6.2
Comment 23 Richard Gate 2001-10-23 08:47:37 EDT
Has there been any progress on this isuue with 7.2?
Comment 24 Matt Darcy 2001-12-16 06:17:50 EST
I am having the same problem using a packardbell spirit 500 with 512 meg or ram 
and an intel pentium 3 500 processor. 

Redhat 7 has installed fine, 7.1 and 7.2 hangs at kswapd. 

an interesting fact is that if I upgrade the kernel to 2.2.19 it works as soon 
as I do it to 2.4 the machine never reboots ? does not get as far as kswapd but 
strange that a 2.4 kernel will not boot and 7.1 and 7.2 start with a 2.4 kernel.

I have not found a way around this and I was hoping that the 7.2 release may 
fix this.
Comment 25 Alan Cox 2002-01-31 06:24:18 EST
Is the hang at kswapd on the cd/floppy boot or after updating and booting from
hard disk ?

Does it occur if you boot with mem=32M ?
Comment 26 Matt Darcy 2002-01-31 07:05:25 EST
Alan,

1.) booting with mem=32 makes no difference. 
2.) the hanging at kswapd starts from any 2.4 kernel.

ie when booting from the 7.1/7.2 cd (2.4 kernel) kswapd hangs. 
when a kernel is upgraded from 2.2.X to 2.4.x it hangs when you boot off the 
disk.
if you compile a kernel to a floppy and boot from the floppy it hangs,
however revert back to a 2.2. kernel and you are away.
Comment 27 Richard Gate 2002-12-27 15:14:54 EST
I have tried to install 7.1, 7.2 and now 8.0 using real RedHat CDs on the same 
system that 7.0 and 6.2 works on and I am still getting this hang. This happens 
when booting from the CD. Having looked at a number of forums and lists it 
seems that this problem has been observed on a number of systems but I cannot 
find anyone who has tied down the reason, let alone tried to fix it. I have a 
system (Packard Bell Spirit) that suffers the problem all the time. Can anyone 
at RedHat suggest anything that I can do to collect more information that will 
help resolve this issue? I have tried all the tests/circumventions mentioned so 
far in this bug report.
Comment 28 Richard Gate 2003-01-15 16:03:25 EST
Can I just check - is anyone looking at this issue?
Comment 29 Alan Cox 2003-01-29 11:03:21 EST
Not actively. 

Comment 30 Matt Darcy 2003-01-29 12:39:43 EST
I have now stopped using the PC I was using for this problem,

I think this needs to be addressed as the HCL for all the compontents in my PC 
was fine with redhat, I had been using redhat 6.2 for a while on this machine, 
I upgraded to 7 fine, thr problem appears to be with th 2.4 kernel.

the redhat products state compatablity yet I have had to stop using this PC 
with redhat.

I think this needs to start being looked at again as redhat 7.1 + advertises 
compatablity with my hardware yet I can't use redhat 7 with a 2.4 kernel or any 
release after 7.

This is "dodgy" ground as according to my box this should run supported.

I'll provide more info to help, scince this machine is doing nothing anymore, 
it seems a shame for other people to have to suffer this.

Matt.
Comment 31 Andre Robatino 2003-01-29 12:45:24 EST
  Have you tried disabling apm with apm=off?
Comment 32 Alan Cox 2003-06-06 09:48:18 EDT
*** Bug 44830 has been marked as a duplicate of this bug. ***
Comment 33 Alan Cox 2003-06-09 13:46:50 EDT
*** Bug 53112 has been marked as a duplicate of this bug. ***
Comment 34 Mayank Kaushik 2003-10-10 14:31:08 EDT
Im facing the same problem while booting up *redhat 9.0*, on my compaq presario 
2262 with a cyrix m2 233, 96 megs of ram, 10 gb hdd, mtd80 based nic. The 
booting stops at 
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)

redhat 8.0 also gave *exactly* the same problem.

And yes, the pre 2.4 kernels boot fine.
Is anyone still working on this problem?
Comment 35 Mayank Kaushik 2003-10-10 16:43:25 EDT
passing the kernel option apm=off through grub at startup solved my 
problem.Thanx to Andre Robatino for the suggestion.
Maybe the problem lies with the Phoenix BIOS that comes with this system.
Just a guess
Thanx ,anyway.
Comment 36 Bugzilla owner 2004-09-30 11:38:58 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.