Bug 391181 - don't rename virbr network devices
don't rename virbr network devices
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 17:45 EST by cje
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-23 05:00:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cje 2007-11-19 17:45:48 EST
there's a rule in /etc/udev/rules.d/75-persistant-net-generator.rules which
stops udev from renaming "Xen virtual interfaces".  should there be one to stop
it from renaming others, such as the "virbr0" that was generated when i made a
VM in virt-manager?

i _suspect_ that this, combined with sky2 net driver weirdness and multiple
network cards, has ended up with very broken networking after upgrade to F8. 
can't prove it though!  i've got the sky2 device with a zero mac address.  i
think that's confusing things.
Comment 1 Harald Hoyer 2007-11-20 05:35:04 EST
Can you show me the rules from /etc/udev/rules.d/70-persistent-net.rules which
is bothering you?
Comment 2 cje 2007-11-22 20:26:16 EST
in 75-persistent-net-generator.rules (not 70-...) there's lines like this:

# device name whitelist
KERNEL!="eth*|ath*|wlan*[0-9]|ra*|sta*|ctc*|lcs*|hsi*",
GOTO="persistent_net_generator_end"

# ignore Xen virtual interfaces
SUBSYSTEMS=="xen", GOTO="persistent_net_generator_end"

and i'm wondering why "virbr*" isn't in either of those rules or another like them.

however:
a) i don't really understand that file so i'm kind of guessing and
b) i saw this when i was trying to track down my network problems and i'd seen
these two lines in dmesg:

virbr0: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.
net virbr0_rename: device_rename: sysfs_create_symlink failed (-17)

but adding "virbr*" to the whitelist line didn't get rid of those messages so i
guess they're not connected anyway.

i probably raised this as 'medium' rather than 'low' because i was so frustrated
with the network mess.  sorry about that.

blimey, i can tell i was tired and annoyed when i raised this.  looking at the
file again i see i missed the "!" in the "KERNEL!=..." line and also missed that
the "xen" line is talking about "SUBSYSTEMS".  :-)
Comment 3 Harald Hoyer 2007-11-23 05:00:56 EST
75-persistent-net-generator.rules only generates rules for you the first time,
it sees an interface. 
You can always put your own rules in 70-persistent-net.rules, which is taken
into account _before_ even 75-persistent-net-generator.rules is executed.
Comment 4 Harald Hoyer 2007-11-23 05:02:16 EST
oh, and 75-persistent-net-generator.rules would only prevent an automatic line
in 70-persistent-net.rules, but not renaming in general.
Comment 5 cje 2007-11-23 07:07:13 EST
ok.  many thanks for that info - that's very useful.  (like, i can actually see
what's going on in that 70-... file!)

Note You need to log in before you can comment on or make changes to this bug.