Bug 391271 - [RHEL5] Evolution crashes when connecting to exchange server
[RHEL5] Evolution crashes when connecting to exchange server
Status: CLOSED DUPLICATE of bug 433648
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.1
All Linux
low Severity urgent
: ---
: ---
Assigned To: Milan Crha
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 19:32 EST by Homayoun Shahri
Modified: 2009-05-01 16:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 12:07:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Homayoun Shahri 2007-11-19 19:32:22 EST
Description of problem:
Evolution crashes when connecting to exchange server. The issue is also reported
by others. It started happening after upgrading to rhel 5.1.

Version-Release number of selected component (if applicable):
evolution-2.8.0-40.el5

How reproducible:
Just start evolution.

Steps to Reproduce:
1. Start evolution
2. Observe the crash
3.
  
Actual results:

(evolution:4551): libsoup-CRITICAL **: soup_message_set_request: assertion
`SOUP_IS_MESSAGE (msg)' failed

(evolution:4551): libsoup-CRITICAL **: soup_message_set_flags: assertion
`SOUP_IS_MESSAGE (msg)' failed

(evolution:4551): libsoup-CRITICAL **: soup_session_send_message: assertion
`SOUP_IS_MESSAGE (msg)' failed


Expected results:
Should connect to exhange server.

Additional info:
This seems to be related to exchange, and I have not tested this update with pop
servers. 
Please also review this related link:
http://ubuntuforums.org/showthread.php?p=3802503
Comment 1 Homayoun Shahri 2007-11-19 19:35:54 EST
I had missed two lines on top of the diagnostic messages that I am coping here:

CalDAV Eplugin starting up ...
** (evolution:4593): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:4593): DEBUG: mailto URL program: evolution

(evolution:4593): libsoup-CRITICAL **: soup_message_set_request: assertion
`SOUP_IS_MESSAGE (msg)' failed

(evolution:4593): libsoup-CRITICAL **: soup_message_set_flags: assertion
`SOUP_IS_MESSAGE (msg)' failed

(evolution:4593): libsoup-CRITICAL **: soup_session_send_message: assertion
`SOUP_IS_MESSAGE (msg)' failed
Comment 2 Homayoun Shahri 2007-11-20 17:25:04 EST
It works with pop servers. I also found out that my company's IT has installed a
new version of exchange. This issue may be related to this new MS software's
functioning with evolution!
Comment 3 Matthew Barnes 2007-11-28 10:57:33 EST
Note that Evolution does not yet work with Exchange 2007, in case that's what
your company has installed.
Comment 4 Matthew Barnes 2008-03-16 18:31:50 EDT
RHEL 5.2 will re-base Evolution from version 2.8.0 to version 2.12.3.
Can you please test whether this bug is still present in RHEL 5.2?
Comment 5 Matěj Cepl 2008-04-17 12:07:47 EDT
Reporter, could you please reply to the previous question?
Comment 6 Homayoun Shahri 2008-05-29 13:31:58 EDT
I have not yet upgraded to RHEL 5.2, but will do that shortly, and will try
Evolution 2.12.3.

Comment 8 Homayoun Shahri 2008-06-26 14:13:06 EDT
I did upgrade to RHEL 5.2. The issue still continues. It is probably due to very
recent version of exchange server that the IT in my company has installed. 

Thanks,
Homayoun
Comment 9 Matthew Barnes 2008-06-26 14:42:35 EDT
If your company has upgraded to Exchange 2007, then the best we can do is make
Evolution fail more gracefully.  Exchange 2007 support is still under heavy
development and not scheduled until RHEL 6.
Comment 10 Homayoun Shahri 2008-06-30 14:09:39 EDT
Yes you're right. I just found out that our IT is using exchange 2007! So I
guess there won't be a solution for a while! 

Thanks,
Homayoun
Comment 11 RHEL Product and Program Management 2008-07-21 19:08:19 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 17 Milan Crha 2009-03-09 12:07:51 EDT
Closing as a duplicate in favor of bug #433648 which is approved for 5.4.

*** This bug has been marked as a duplicate of bug 433648 ***

Note You need to log in before you can comment on or make changes to this bug.