Bug 391321 - yum can't install tzdata package
Summary: yum can't install tzdata package
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 7
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-20 01:10 UTC by Tim McConnell
Modified: 2014-01-21 23:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 14:56:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim McConnell 2007-11-20 01:10:11 UTC
Description of problem: when I attempt to update tzdata I receive errors  


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. run yum update 
2.yum finds update packages 
3.tzdata won't install 
  
Actual results:
tzdata update not installed with errors:
Error unpacking rpm package tzdata - 2007i-1.fc7.noarch
error: unpacking of archive failed on file /usr/share/zoneinfo/Etc/GMT: cpio: rename


Expected results:
Update to install 

Additional info: 
[root@timmieland ~]# yum update
Loading "protect-packages" plugin
Loading "merge-conf" plugin
Loading "kernel-module" plugin
Loading "priorities" plugin
Loading "protectbase" plugin
Loading "presto" plugin
Loading "security" plugin
Loading "skip-broken" plugin
Loading "fedorakmod" plugin
Loading "fastestmirror" plugin
Loading "allowdowngrade" plugin
Loading "tsflags" plugin
Setting up Presto
livna-development-debugin 100% |=========================| 1.9 kB    00:00     
livna                     100% |=========================| 2.1 kB    00:00     
livna-debuginfo           100% |=========================| 1.9 kB    00:00     
fedora                    100% |=========================| 2.1 kB    00:00     
adobe-linux-i386          100% |=========================|  951 B    00:00     
updates-debuginfo         100% |=========================| 1.9 kB    00:00     
fedora-debuginfo          100% |=========================| 1.9 kB    00:00     
updates                   100% |=========================| 2.3 kB    00:00     
kagesenshi                100% |=========================| 1.9 kB    00:00     
Reading Presto metadata in from local files
Loading mirror speeds from cached hostfile
primary.sqlite.bz2        100% |=========================|  38 kB    00:05     
primary.sqlite.bz2        100% |=========================| 153 kB    00:11     
primary.sqlite.bz2        100% |=========================|  50 kB    00:03     
primary.sqlite.bz2        100% |=========================| 3.8 MB    00:29     
primary.xml.gz            100% |=========================| 1.3 kB    00:00     
adobe-linu: ################################################## 2/2
primary.sqlite.bz2        100% |=========================| 451 kB    00:03     
primary.sqlite.bz2        100% |=========================| 849 kB    00:06     
primary.sqlite.bz2        100% |=========================| 1.9 MB    00:14     
primary.sqlite.bz2        100% |=========================|  20 kB    00:00     
0 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package tzdata.noarch 0:2007i-1.fc7 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 tzdata                  noarch     2007i-1.fc7      updates           747 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 747 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): tzdata-2007i-1.fc7 100% |=========================| 747 kB    00:05     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : tzdata                       ######################### [1/2] 
Error unpacking rpm package tzdata - 2007i-1.fc7.noarch
error: unpacking of archive failed on file /usr/share/zoneinfo/Etc/GMT: cpio: rename

Updated: tzdata.noarch 0:2007i-1.fc7
Complete!

Comment 1 Jeremy Katz 2007-11-20 01:54:10 UTC
What does 'ls -l /usr/share/zoneinfo/Etc/GMT' show?

Comment 2 Tim McConnell 2007-11-21 04:25:06 UTC
[root@timmieland ~]# ls -l /usr/share/zoneinfo/Etc/GMT
ls: cannot access /usr/share/zoneinfo/Etc/GMT: No such file or directory
[root@timmieland ~]# ls -l /usr/share/zoneinfo/etc/GMT
ls: cannot access /usr/share/zoneinfo/etc/GMT: No such file or directory


Comment 3 Tim McConnell 2007-12-06 14:55:27 UTC
fixed by renaming zoneinfo to zoneinfo.old and forcing a new install of tzdata


Note You need to log in before you can comment on or make changes to this bug.