Bug 39168 - g++ error "Internal compiler error in "
g++ error "Internal compiler error in "
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-04 19:48 EDT by Peng Zhao
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 19:52:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
temporary file (.ii) generated with gcc version 2.96 20000731 (Red Hat Linux 7.0) (1.11 MB, patch)
2001-05-04 19:50 EDT, Peng Zhao
no flags Details | Diff

  None (edit)
Description Peng Zhao 2001-05-04 19:48:48 EDT
Description of Problem: g++  --> "Internal compiler error in "


How Reproducible:
g++ -D_SGI_SOURCE -D_LANGUAGE_C_PLUS_PLUS -Wformat -funsigned-char
-D__GNU_BUG_WORKAROUND -D_NOTHREADS -c            -Dsgi -DBACK_END
-DMONGOOSE_BE -Dlonglong -D_LONGLONG -D_SVR4_SOURCE -LANG:packed=on
-DIs_True_On -D__MIPS_AND_IA64_ELF_H -I. -I../../be/cg
-I../../be/cg/gra_mon -I../../be/cg/ia64 -I../../common/com
-I../../common/com/ia64 -I../../common/util -I../../common/stl
-I../../be/com -I../../be/region -I../../be/prompf_anl -I../../be/opt
-I../../common/targ_info/access -I../targ_info -I../be -I../include/libelf
-fPIC -DTARG_IA64  -fwritable-strings  -I../include  -g -D_MIPSEL
-D_LONGLONG -D_MIPS_SZINT=32 -D_MIPS_SZPTR=32 -D_MIPS_SZLONG=32 -MD
../../be/cg/cgemit.cxx -o cgemit.o


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
../../be/cg/cgemit.cxx: In function `void Init_Sanity_Checking_For_BB 
()':
../../be/cg/cgemit.cxx:1531: Internal compiler error in 
print_operand_address, at config/i386/i386.c:3404
Please submit a full bug report.


Expected Results:


Additional Information:
Comment 1 Peng Zhao 2001-05-04 19:50:53 EDT
Created attachment 17406 [details]
temporary file (.ii) generated with gcc version 2.96 20000731 (Red Hat Linux 7.0)
Comment 2 Peng Zhao 2001-05-04 19:51:57 EDT
sakwatamau:/nue/usr/brule12/grad/pengzhao/pro64> gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.0)

sakwatamau:/nue/usr/brule12/grad/pengzhao/pro64> uname -a
Linux sakwatamau 2.2.16-3 #17 Tue Nov 28 11:36:11 MST 2000 i686 unknown
Comment 3 Jakub Jelinek 2001-05-05 13:50:41 EDT
This one is fixed since at least g++-2.96-64, so if you try either the
official 7.0 errata (2.96-69) or 7.1 g++ (2.96-81) you should be fine.

Note You need to log in before you can comment on or make changes to this bug.