Bug 39169 - gcc version 2.96 20000731 (Red Hat Linux 7.0) ( invalid character '=' in operand 1 AND Bad expression)
gcc version 2.96 20000731 (Red Hat Linux 7.0) ( invalid character '=' in op...
Status: CLOSED DUPLICATE of bug 39170
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-04 20:00 EDT by Peng Zhao
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 20:01:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
temp file generated (.ii) with "save-temps" on (967.85 KB, patch)
2001-05-04 20:01 EDT, Peng Zhao
no flags Details | Diff

  None (edit)
Description Peng Zhao 2001-05-04 20:00:15 EDT
Description of Problem:
/tmp/cc6KgW7V.s:2139: Error: invalid character '=' in operand 1
/tmp/cc6KgW7V.s:10418: Warning: missing operand; zero assumed
/tmp/cc6KgW7V.s:10421: Error: Rest of line ignored. First ignored character
is `='.
/tmp/cc6KgW7V.s:10422: Error: ignoring unrecognized symbol type ""
/tmp/cc6KgW7V.s:10422: Error: Rest of line ignored. First ignored character
is `='.
/tmp/cc6KgW7V.s:10423: Error: Bad expression
/tmp/cc6KgW7V.s:10427: Error: Rest of line ignored. First ignored character
is `='.
/tmp/cc6KgW7V.s:10436: Error: Rest of line ignored. First ignored character
is `='.
/tmp/cc6KgW7V.s:10453: Error: Rest of line ignored. First ignored character
is `='.
/tmp/cc6KgW7V.s:10459: Error: expected comma after name `operator' in .size
directive
/tmp/cc6KgW7V.s:10459: Error: Rest of line ignored. First ignored character
is `='.
/tmp/cc6KgW7V.s:10463: Error: Rest of line ignored. First ignored character
is `='.


How Reproducible:
g++ -D_SGI_SOURCE -D_LANGUAGE_C_PLUS_PLUS -Wformat -funsigned-char
-D__GNU_BUG_WORKAROUND -D_NOTHREADS -c            -Dsgi -DMONGOOSE_BE
-D_LIGHTWEIGHT_INLINER -Dlonglong -D_LONGLONG -D_SVR4_SOURCE -D_NEW_SYMTAB
-DIs_True_On -DInsist_On  -I../../ipa/common -I../../ipa/local
-I../../ipa/main/analyze -I../../ipa/main/optimize -I../../ipa/inline
-I../../common/com -I../../be/com -I../../be/region -I../../be/opt
-I../../be/lno -I../../common/com/ia64 -I../../common/util -I../be
-I../../be/vho -fPIC -DTARG_IA64    -I../include  -g -D_MIPSEL -D_LONGLONG
-D_MIPS_SZINT=32 -D_MIPS_SZPTR=32 -D_MIPS_SZLONG=32 -MD
../../ipa/common/ipc_bread.cxx -o ipc_bread.o


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
g++ -D_SGI_SOURCE -D_LANGUAGE_C_PLUS_PLUS -Wformat -funsigned-char
-D__GNU_BUG_WORKAROUND -D_NOTHREADS -c            -Dsgi -DMONGOOSE_BE
-D_LIGHTWEIGHT_INLINER -Dlonglong -D_LONGLONG -D_SVR4_SOURCE -D_NEW_SYMTAB
-DIs_True_On -DInsist_On  -I../../ipa/common -I../../ipa/local
-I../../ipa/main/analyze -I../../ipa/main/optimize -I../../ipa/inline
-I../../common/com -I../../be/com -I../../be/region -I../../be/opt
-I../../be/lno -I../../common/com/ia64 -I../../common/util -I../be
-I../../be/vho -fPIC -DTARG_IA64    -I../include  -g -D_MIPSEL -D_LONGLONG
-D_MIPS_SZINT=32 -D_MIPS_SZPTR=32 -D_MIPS_SZLONG=32 -MD
../../ipa/common/ipc_bread.cxx -o ipc_bread.o

In file included from ../../be/com/fb_whirl.h:67,
                 from ../../ipa/local/ipl_summary.h:76,
                 from ../../ipa/main/analyze/ipa_cg.h:65,
                 from ../../ipa/common/ipc_symtab_merge.h:107,
                 from ../../ipa/common/ipc_bread.cxx:52:
../../common/com/fb_info.h:142:2: warning: multi-line comment
../../common/com/fb_info.h:145:2: warning: multi-line comment
/tmp/cc6KgW7V.s: Assembler messages:
/tmp/cc6KgW7V.s:2139: Error: invalid character '=' in operand 1
/tmp/cc6KgW7V.s:10418: Warning: missing operand; zero assumed
/tmp/cc6KgW7V.s:10421: Error: Rest of line ignored. First ignored character
is `='.
/tmp/cc6KgW7V.s:10422: Error: ignoring unrecognized symbol type ""
/tmp/cc6KgW7V.s:10422: Error: Rest of line ignored. First ignored character
is `='.
/tmp/cc6KgW7V.s:10423: Error: Bad expression
/tmp/cc6KgW7V.s:10427: Error: Rest of line ignored. First ignored character
is `='.
/tmp/cc6KgW7V.s:10436: Error: Rest of line ignored. First ignored character
is `='.
/tmp/cc6KgW7V.s:10453: Error: Rest of line ignored. First ignored character
is `='.
/tmp/cc6KgW7V.s:10459: Error: expected comma after name `operator' in .size
directive
/tmp/cc6KgW7V.s:10459: Error: Rest of line ignored. First ignored character
is `='.
/tmp/cc6KgW7V.s:10463: Error: Rest of line ignored. First ignored character
is `='.
gmake[1]: *** [ipc_bread.o] Error 1


Expected Results:


Additional Information:
sakwatamau:/nue/usr/brule12/grad/pengzhao/pro64>  g++ -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.0)
sakwatamau:/nue/usr/brule12/grad/pengzhao/pro64> uname -a
Linux sakwatamau 2.2.16-3 #17 Tue Nov 28 11:36:11 MST 2000 i686 unknown
Comment 1 Peng Zhao 2001-05-04 20:01:07 EDT
Created attachment 17407 [details]
temp file generated (.ii) with "save-temps" on
Comment 2 Jakub Jelinek 2001-05-05 13:10:29 EDT

*** This bug has been marked as a duplicate of 39170 ***

Note You need to log in before you can comment on or make changes to this bug.