Bug 39209 - Installer crashes when IBM Microdrive or Compact flash jumpered as master on IDE bus
Installer crashes when IBM Microdrive or Compact flash jumpered as master on ...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-05 10:18 EDT by Rick Moseley
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-20 13:25:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Moseley 2001-05-05 10:18:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win98; U)

Description of problem:
The 7.0 install worked fine on my configuration of a Compact flash (64 MB) or IBM Microdrive (340 MB) jumpered as the master device on an 
IDE bus.  The drive that is jumpered as a slave is a 15 GB Maxtor model 2R015H1.  When I tried to upgade this configuration the 7.1 installer 
does not even recognize the 15 GB drive.  Leaving the hardware alone and booting from a 7.0 boot disk it sees the drive just fine.  I can jumper 
the 15 GB drive as master and the 7.1 installer sees it fine.  I have tried both of the above described procedures on two different mother boards 
(Dell and ASUS) with the same results.

When I tried to do an install with either the microdrive or compact flash jumpered as master I get the following output from anaconda:

Running anaconda - please wait
Probing for mouse type...
Waiting for X server to start...log located in /tmp/X.log
.. Xserver started successfully.
     (at this point the screen jumps into the mode for X and the initial install screen comes up for about 1-2 seconds and then I get the
       following messages)
install exited abnormally
sending termination signals...done
sending kill signals...md:recovery thread got woken up...
md: recovery thread finished...
mdrecovery(7) flushing signals.
done
disabling swap...
unmounting filesystems
  /proc/bus/usb
  /mnt/runtime
  /mnt/source umount failed()
  /dev/pts
  /proc
you may safely reboot your system

When jumpered as master I can do a full 7.1 install on the 15 GB drive.

The major problem I have is that the compact flash and the microdrive MUST be jumpered as master on the IDE bus or they won't work.  Not 
sure why, but that is the case.  This is causing a major problem with my development of my embedded system project in the Red Hat office in 
Huntsville.

As I said earlier, the 7.0 handled this situation OK.  The only thing I let the install put on the compact flash or microdrive is the lilo information 
in 
the MBR.  The rest of the install goes onto the slave drive.

How reproducible:
Always

Steps to Reproduce:
1.Configure an IDE bus with a compact flash or microdrive as master drive with another drive as slave
2.try to boot the 7.1 install CD and perform an install
3.
	

Additional info:
Comment 1 Brent Fox 2001-05-05 20:15:21 EDT
What if you boot with the 'linux ide=nodma' boot option?  I don't know if the
2.4 kernel supports these devices.
Comment 2 Rick Moseley 2001-05-06 11:31:10 EDT
When I use the "linux ide=nodma" option on the installer I get further along the
install process.  When I get to the part where I partition the drives I get the
following error in a box:

"An error occurred reading the partition table for the block device hda.  The
error was:

Partition(s) do not end on cylinder boundary

This occurs because the drive geometry detected by the kernel used by the
installer is different than the drive geometry used when the drive was
partitioned.  This can be corrected by specifying the drive geometry on the
kernel command line when booting the installer."

I then skip the drive and get told that "no valid devices were found on which to
create new filesystems" even though I have the 15 GB drive jumpered as a slave
drive.

If the 2.4+ kernels do not support these devices then you can effectively say
Red Hat is out of the embedded Linux market.
Comment 3 Brent Fox 2001-05-07 11:30:13 EDT
Have you run any of the 7.1 betas on this device?  I would try fdisking the
drive and wipe all partitions off the drive and then try the install again
(still using the ide=nodma option).  Does this help?

About the 2.4 kernel and embedded devices...I have no experience with these kind
of devices, so I don't know what is supported and what isn't.  I think what I
meant by that was that I don't know if the kernel that we ship with the 7.1
installer has support for these devices enabled.  Apparently it does, since it
is trying to access the device, but it's finding an unfamiliar partition table.
 I think wiping the drive and starting fresh should work.
Comment 4 Rick Moseley 2001-05-10 10:58:06 EDT
Sorry it took so long to get back, I had a delivery to our customer this week.

I was able to try the "ide=nodma" idea to no avail.  I was able to fdisk and
repartition the IBM 340MB microdrive disk with the 7.0 install CD but NOT the
7.1 install CD.  After repartitioning the disk with the 7.0 fdisk I was able to
see it with the 7.1 install CD.  Now the problem is I canot see the second drive
(15GB Maxtor) jumpered as slave on the IDE bus even though I can see it in the
BIOS setup.  The 7.0 installer sees both drives and their partition tables OK.

I guess the question now is why the 7.1 installer will see a 340MB IBM
microdrive jumpered as master but won't see any other drives even though the 7.0
installer will on the same exact configuration.
Comment 5 Brent Fox 2001-05-10 16:10:56 EDT
Boot into the 7.1 installer and then go to VC2 and look around in /proc/ide.  Do
you see 'hdb' or something else that indicates that the kernel is even seeing
the device.  If the kernel can't talk to the device, then there's no hope of
anaconda seeing it.
Comment 6 Brent Fox 2001-05-20 13:24:58 EDT
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.