Bug 392201 - kickstart upgrade does not execute scripts in %post section
kickstart upgrade does not execute scripts in %post section
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 08:21 EST by Jean Visagie
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 10:51:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean Visagie 2007-11-20 08:21:01 EST
Description of problem:

With a custom fedora distro, i.e. used build-install, pgkorder, etc., Kickstart
upgrade does not execute %post section of script. Nor tested on stock-standard
fedora distro, but pretty sure it will also happen with stock-standard one used
along with kickstart.

Version-Release number of selected component (if applicable):

11.3.0.50-2

How reproducible:

Very reproducible(Everytime)

Steps to Reproduce:
1. Edit isolinux.cfg to include append ks=cdrom:/blah.cfg
2. blah.cfg contain 'upgrade' along with other needed stuff and a %post section
3. boot cd and enjoy. ;-)
  
Actual results:

%post script does not execute.

Expected results:

%post script supposed to execute

Additional info:

The 'upgrade.py' file in the minstg2.img and stage2.img does not contains
"postscripts" in the dispatch.setStepList. If I add this it works fine. Been
this way since F7. Why did kickstart all of a sudden break from fedora 7?
Comment 1 Chris Lumens 2007-11-20 10:51:02 EST
I don't know why it was removed, but it's been added back in now.  Thanks for
the bug report.

Note You need to log in before you can comment on or make changes to this bug.