Bug 39230 - ifup not returning after setting up a ppp link (sometimes)
ifup not returning after setting up a ppp link (sometimes)
Status: CLOSED DUPLICATE of bug 39543
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-05 15:49 EDT by Carlos Rodrigues
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-11 21:27:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2001-05-05 15:49:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Sometimes (I haven't figured out the causes) when I do /sbin/ifup pppX it
never returns altough the link is up and usable. I've tried with more than
one ISP and it still happens.
When the problem happens, running top shows two ppp-watch processes along
with pppd.

How reproducible:
Sometimes

Steps to Reproduce:
1. /sbin/ifup ppp0
2.
3.
	

Actual Results:  Sometimes I never get the command prompt back

Expected Results:  It should have returned to the command prompt after the
link was up.

Additional info:

I'm running ipcheck from /etc/ppp/ip-up.local to update my dyndns.org
account but it updates and returns normally (specifically when the problem
occurs).
I'm using ppp over a 56K modem line to my ISP.
Comment 1 Bill Nottingham 2001-05-07 09:45:36 EDT
ifup-ppp is syncrhonous. It should only return when the link goes down, or,
if you call it when it's already up, after initiating a redial.
Comment 2 Carlos Rodrigues 2001-05-07 18:50:27 EDT
I've always used /sbin/ifup to bring up my ppp link and /sbin/ifdown to bring 
it down and before redhat 7.1 it returned back to the command line 100% of the 
times, now it only returns 90%.
Comment 3 Carlos Rodrigues 2001-05-13 14:10:45 EDT

*** This bug has been marked as a duplicate of 39543 ***

Note You need to log in before you can comment on or make changes to this bug.