Bug 39237 - Shell job control problems in Rawhide 20010503
Shell job control problems in Rawhide 20010503
Status: CLOSED DUPLICATE of bug 36839
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-05 19:48 EDT by dunwoody
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-06 15:07:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dunwoody 2001-05-05 19:48:23 EDT
I updated my systems from Rawhide 20010310 to Rawhide 20010503, and
now I am having problems with shell job control.  The fix may well be
a simple configuration change to my systems, but as yet I have found
no such fix.  I would like to know if anyone else can reproduce this
problem on a different installation of Rawhide 20010503.

I listed the "Component" as "kernel", but I don't have any idea which
component is the culprit.

The simplest manifestation of the problem is that job control
(e.g. intr=^C) does not work for shells (either bash or tcsh) started
via login on the text console or via rlogin.  I am starting these
shells with no personal .rc file (just the standard system .rc).

After I have started X via /usr/X11R6/bin/startx, I have no problem
with job control on shells started under xterm or emacs.

If I start a bash via text console login or rlogin, job control will
not work.  If I then start another bash via /bin/su, I get the msg

    bash: no job control in this shell

If I start a tcsh, I get the msg

    Warning: no access to tty (Inappropriate ioctl for device).
    Thus no job control in this shell.

Another problem that I noticed is that the sh script that starts
StarOffice 5.2 doesn't work (just hangs), but if I start the
StarOffice binary directly, it works fine.

I don't see any of these problems on my Rawhide 20010310 systems.  So
far, I have individually tried 20010310 versions of the following RPMS
on my 20010503 systems, so far with no change in the observed
problems:

    kernel-*
    glibc-*
    SysVinit
    mingetty
    bash
    tcsh

I also tried remaking devices on my 20010503 system via

    /dev/MAKEDEV console
    /dev/MAKEDEV tty
    /dev/MAKEDEV pty

also without any change in the problem behavior.

One thing that I noticed via strace is that the shells (bash and tcsh)
get ENOTTY (inapropriate ioctl for device) error returns from calls to
ioctl(i, TCGETS, p).  This seems to happen both when the
no-job-control problem is present (e.g. text-console on 20010503) and
when it is not (e.g. xterm on 20010503, text-console on 20010310).
I'm wondering if there is something else going on that causes these
errors to be a problem in 20010503.

I'm sure that there is a simple explanation and fix for these
problems, but I'm stumped and would greatly appreciate any clues that
you could provide.  If necessary, I'd be happy to provide additional
details about my system configuration (e.g. the set of installed
RPMs).
Comment 1 Arjan van de Ven 2001-05-06 05:43:48 EDT
Can you do me a favour and give the exact kernel version you are using?
(uname -r will tell you)
Comment 2 dunwoody 2001-05-06 11:09:52 EDT
Perhaps I should have been clearer in the original bug report that the only
reason that I listed "kernel"
as the "Component" is that I don't know which component is causing the problem. 
I initially tried to put the free text "component unknown" in the "Component
text" field, but that produced an error when I submitted
the bug.

I am running kernel version 2.4.3-2.14.10 on my Rawhide 20010503 systems.
I am using the .i586.rpm on a PII and the .i686.rpm on a PIII,
and I see the same job-control problem on both systems.  I also tried running
kernel-2.4.3-2.14.14.i386.rpm on the same 20010503 systems, with no change in
the job-control problem. 
The Rawhide 20010503 release seems to have a complete set of 2.4.3-2.14.10
kernels and an incomplete
set of 2.4.3-2.14.14 kernels.

I am NOT seeing this problem on my Rawhide 20010310 systems, which are running
kernel-2.4.2-0.1.25 .
I tried this 2.4.2-0.1.25 kernel on my 20010503 systems, and still saw the
job-control problem.  This
definitely suggests that the problem is NOT the kernel itself, but perhaps an
interaction between some
library or utility component and the kernel.
Comment 3 Arjan van de Ven 2001-05-06 11:18:47 EDT
There has been a slight change in the kernel where on fork() the child is
now executed first; we were considering backing that out and this bugreport
convinces me that we really should. That it works in X is strange.
The other thing we changed recently was to increase the number of pty's from 256 
to 2048, although I fail to see how that could break stuff.
Comment 4 dunwoody 2001-05-06 11:46:27 EDT
arjanv@redhat.com writes:
> There has been a slight change in the kernel where on fork() the child is
> now executed first; we were considering backing that out and this bugreport
> convinces me that we really should. That it works in X is strange.
> The other thing we changed recently was to increase the number of pty's from
256 
> to 2048, although I fail to see how that could break stuff.

Interesting.  Can you reproduce the problem I'm seeing (no ^C on text console)
on any of your systems?
Did either of the two kernel changes you mentioned go in between 2.4.2-0.1.25
and 2.4.3-2.14.10?

Were there any non-kernel changes that went along with these changes?  I still
can't figure out why
I don't see the job-control problem with 2.4.2-0.1.25 kernel and the other RPMs
from Rawhide-20010310,
but I do see the job-control problem with the same 2.4.2-0.1.25 kernel and the
other RPMs from
Rawhide-20010503.

I know very little about the details of pty's and tty's, but one thing I noticed
on my systems is that after
running the /dev/MAKEDEV script from the latest MAKEDEV-3.1.0-15 RPM,  and
remaking the
"console", "tty", and "pty" devices, I now have only 256 /dev/pty* device files
and 2593 /dev/tty* device files.
Was "/dev/MAKEDEV pty" supposed to have created 2048 /dev/pty* device files?
Comment 5 Arjan van de Ven 2001-05-06 14:26:06 EDT
The changes went in in the 2.4.3 series. If you see this with 2.4.2 kernels
as well, it doesn't look like a kernel problem. I'll assign the bug to glibc
as that would be component that could cause this for both bash and tcsh.

Jakub: feel free to assign the bug back if you think glibc has nothing to do 
with this.
Comment 6 dunwoody 2001-05-06 15:07:49 EDT
What is surprising to me about the problem I'm seeing is that it doesn't seem to
be specific to a
single RPM.  To clarify what I wrote in the original bug report, I have two sets
of systems: those running
pure Rawhide 20010310, which all do NOT have the job-control problem, and those
running pure
Rawhide 20010503,  which all do have the the job-control problem.

The pure Rawhide 20010503 systems are running:
	kernel-2.4.3-2.14.10
	glibc-*-2.2.3-5
	SysVinit-2.78-15
	mingetty-0.9.4-17
	util-linux-2.11a-4
	bash-2.05-3
	tcsh-6.10-5
I would expect that if you ran this set of RPMs on a system in your lab, you
would
have no job control on a text-console shell.  If you can't reproduce the problem
in this way,
then either the problem is in some other RPM, or there
is something strange about the way that I have configured my systems.

The pure Rawhide 20010310 systems are running:
	kernel-2.4.2-0.1.25
	glibc-*-2.2.2-5
	SysVinit-2.78-12
	mingetty-0.9.4-15
	util-linux-2.10s-8
	bash-2.04-21
	tcsh-6.10-4

So far, I have tried some simple RPM-replacement experiments on my pure Rawhide
20010503 systems.
For each of the RPMs that I listed, one at a time, I tried replacing the
20010503 version with the
20010310 version.  Every time, I still saw the job-control problem.  So it seems
like multiple RPMs are
involved.  What I have NOT yet tried is simultaneously switching multiple RPMs
(e.g. kernel and glibc)
to the 20010310 version.

Just to be clear, modifying my pure Rawhide 20010503 system to use the
known-good 20010310
version of glibc-* did NOT make the job-control problem go away.  So it doesn't
seem to be purely
a glibc problem.

The complete list of RPMs on my pure Rawhide 20010503 systems is as follows:
bison-1.28-5
ORBit-0.5.7-3
dev86-0.15.0-5
socks5-1.0r11-2
cracklib-2.7-8
psutils-1.17-10
less-358-16
rpmfind-1.6-5
pwdb-0.61.1-1
patch-2.5.4-9
chkconfig-1.2.22-1
alchemist-0.16-3
GConf-1.0.0-3
kernel-doc-2.4.3-2.14.14
gnupg-1.0.5-1
compat-egcs-6.2-1.1.2.14
minicom-1.83.1-6
procps-2.0.7-8
telnet-0.17-11
kernel-pcmcia-cs-3.1.24-3
tmpwatch-2.7.1-1
samba-2.0.8-0.7.1
gnome-libs-1.2.13-1
pygtk-libglade-0.6.6-8
Mesa-devel-3.4-13
kernel-2.4.3-2.14.10
logrotate-3.5.4-1
setserial-2.17-2
efax-0.9-8
ghostscript-fonts-5.50-3
nmh-1.0.4-8
crontabs-1.9-2
chkfontpath-1.9.5-1
flex-2.5.4a-13
indent-2.2.6-1
freeamp-2.0.8-3
urw-fonts-2.0-12
perl-SGMLSpm-1.03ii-4
mpg123-0.59r-10
RealPlayer-8.0-1
sendmail-doc-8.11.2-14
timeconfig-3.2-1
vnc-server-3.3.3r2-14
xmon-1.5.4-0
gv-3.5.8-11
lgtoman-rh-5.1.0-2
xv-3.10a-23
jadetex-3.3-1
db3-3.1.17-6
gnome-audio-1.4.0-1
libxml-1.8.11-2
hotplug-2001_02_14-15
libxml-devel-1.8.11-2
compat-egcs-c++-6.2-1.1.2.14
dev-3.1.0-15
ncftp-3.0.3-1
perl-5.6.0-12
psmisc-20.1-1
setup-2.4.9-1
termcap-11.0.1-8
mkinitrd-3.0.10-1
php-4.0.4pl1-11
openjade-1.3-14
kernel-headers-2.4.3-2.14.10
vim-common-6.0-0.29
XFree86-ISO8859-2-75dpi-fonts-4.0.3-11
gdk-pixbuf-0.10.1-1
mozilla-psm-0.8.1-5
pygnome-libglade-0.6.6-8
XFree86-devel-4.0.3-11
XFree86-tools-4.0.3-11
control-center-1.4.0.1-2
ptools-v3.8-1
xsane-0.62-4
autoconf-2.13-10
sendmail-cf-8.11.2-14
libtermcap-2.0.8-26
passwd-0.64.1-4
rsync-2.4.6-2
fortune-mod-1.2.1-1
yp-tools-2.4-7
ppp-2.4.0-2
gzip-1.3-12
bdflush-1.5-16
libpng-1.0.11-2
iproute-2.2.4-11
cpp-2.96-84
netscape-common-4.77-1
rawhide-release-20010503-1
tetex-doc-1.0.7-16
autofs-3.1.7-16
tetex-afm-1.0.7-16
vim-minimal-6.0-0.29
gimp-1.2.1-5
printconf-gui-0.2.12-1
xinetd-2.1.8.9pre14-9
mkisofs-1.9-6
cpio-2.4.2-20
lsof-4.51-1
redhat-logos-1.1.2-3
db1-1.85-5
sudo-1.6.3p6-1
vnc-3.3.3r2-14
ncurses4-5.0-2
cracklib-dicts-2.7-8
glaze-1.0-1
ld.so-1.9.5-13
mtools-3.9.7-4
psgml-1.2.1-13
pgp-6.5.1-free-rsaref
compat-libs-6.2-3
sgml-tools-1.0.9-9
python-1.5.2-30
xcdroast-0.98a8-2
netpbm-9.9-5
traceroute-1.4a5-25
mailx-8.1.1-20
zip-2.3-8
sane-1.0.3-10
enscript-1.6.1-12
lilo-21.4.4-13
tkdiff-6.3-1
bzip2-libs-1.0.1-4
compat-libstdc++-6.2-2.9.0.14
glib-1.2.10-2
libtool-libs-1.3.5-9
bash-2.05-3
libstdc++-2.96-84
mpage-2.5.1-6
emacs-20.7-36
gdb-5.0rh-8
ntp-4.0.99k-16
ncurses-devel-5.2-9
ftp-0.17-9
newt-0.50.22-2
texinfo-4.0a-1
pam-0.75-1
php-manual-4.0.4pl1-11
docbook-style-dsssl-1.64-1
docbook-utils-pdf-0.6-13
openssh-clients-2.5.2p2-6
stunnel-3.14-1
freetype-utils-2.0.1-5
libglade-0.16-1
pilot-link-0.9.5-3
rep-gtk-gnome-0.15-5
XFree86-xfs-4.0.3-11
imap-2000-9
gnome-applets-1.2.4-3
which-2.12-1
rdist-6.1.5-14
bc-1.06-2
compat-glibc-6.2-2.1.3.2
gphoto-0.4.3-10
tcl-8.3.2-50
runsocks-1.0r11-2
hdparm-3.9-6
performer_demos-2.3.1-10
m4-1.4.1-4
shadow-utils-20000826-4
sendmail-8.11.2-14
zlib-1.1.3-22
gnuplot-3.7.1-12
acroread-4.05-5
unix2dos-2.2-11
automake-1.4-8
dialog-0.9a-4
sh-utils-2.0-13
esound-0.2.22-1
utempter-0.5.2-4
libc-5.3.12-31
sox-12.17.1-2
socks5-clients-1.0r11-2
ncurses3-1.9.9e-11
isapnptools-1.22-2
t1lib-1.0-5
acroread-plugin-4.05-5
cdrecord-1.9-6
grep-2.4.2-5
sysklogd-1.4-7
authconfig-4.1.6-1
vnc-doc-3.3.3r2-14
Xaw3d-1.5-9
zlib-devel-1.1.3-22
slocate-2.5-5
gd-1.8.3-7
rcs-5.7-14
db2-2.4.14-5
gnome-users-guide-1.2-3
rpm2html-1.5-4
make-3.79.1-5
aumix-2.7-2
time-1.7-13
gtkdiff-1.0.2-3
bzip2-1.0.1-4
devfsd-2.4.3-2.14.10
gdbm-1.8.0-6
iputils-20001110-2
libtiff-3.5.5-10
mingetty-0.9.4-17
glib-devel-1.2.10-2
krb5-libs-1.2.2-5
groff-1.16.1-8
modutils-2.4.5-1
binutils-2.10.91.0.2-3
diffutils-2.7.2-1
at-3.1.8-16
gcc-c++-2.96-84
man-1.5i-2
net-tools-1.60-1
fetchmail-5.8.1-2
libtool-1.3.5-9
procmail-3.15.1-1
readline-4.1-9
rsh-0.17-2.7
slang-1.4.4-1
tcsh-6.10-5
tetex-fonts-1.0.7-16
caching-nameserver-7.1-3
cyrus-sasl-1.5.24-18
openldap-2.0.7-15
rpm-4.0.3-0.12
samba-client-2.0.8-0.7.1
docbook-utils-0.6-13
tetex-1.0.7-16
tetex-dvips-1.0.7-16
initscripts-5.86-1
openssh-2.5.2p2-6
nfs-utils-0.3.1-8
words-2-17
XFree86-doc-4.0.3-11
emacs-X11-20.7-36
imlib-1.9.10-1
gnome-print-0.28-6
mozilla-0.8.1-5
openssh-askpass-gnome-2.5.2p2-6
pygnome-1.4.0-8
rep-gtk-0.15-5
plugger-3.3-1
gimp-devel-1.2.1-5
Mesa-demos-3.4-13
finger-server-0.17-9
xpdf-0.92-4
gnome-core-1.4.0.2-2
kernel-smp-2.4.3-2.14.10
glibc-2.2.3-5
gnome-vfs-1.0-1
mailcap-2.1.4-2
mikmod-3.1.6-10
grip-2.94-7
unzip-5.41-3
performer_dev-2.3.1-10
findutils-4.1.6-2
file-3.33-1
ElectricFence-2.2.2-7
symlinks-1.2-11
performer_eoe-2.3.1-10
libungif-4.1.0-7
cvs-1.11-3
sharutils-4.2.1-7
ggv-0.82-5
dhcp-2.0pl5-4
pump-0.8.11-1
gnome-media-1.2.0-12
lgtoclnt-rh-5.1.0-2
extace-1.4.4-2
tamago-4.0.6-4
byacc-1.9-18
libgnomeprint15-0.28-6
db3-utils-3.1.17-6
indexhtml-7.1-2
losetup-2.11b-3
freetype-devel-2.0.1-5
freetype-2.0.1-5
info-4.0a-1
fileutils-4.0.43-1
kernel-source-2.4.3-2.14.14
bind-utils-9.1.2-0.rc1.1
procinfo-18-1
mysql-3.23.37-1
stat-2.2-2
textutils-2.0.13-1
gpm-1.19.3-16
rpm-build-4.0.3-0.12
sndconfig-0.64.8-1
util-linux-2.11a-4
portmap-4.0-37
XFree86-75dpi-fonts-4.0.3-11
gtk+-1.2.10-1
gtop-1.0.13-1
pygtk-0.6.6-8
smpeg-0.4.3-1
Mesa-3.4-13
wu-ftpd-2.6.1-16
ypbind-1.7-7
cdda2wav-1.9-6
glload-0.4.2-4
uucp-1.06.1-26
vixie-cron-3.0.1-62
lesstif-0.91.0-4
lesstif-1.2-devel-0.91.0-4
gawk-3.0.6-1
4Suite-0.10.1-1
VFlib2-2.25.1-12
xtt-fonts-0.19990222-9
wget-1.6-2
awesfx-0.4.3a-7
routed-0.17-6
glibc-common-2.2.3-5
e2fsprogs-1.19-4
man-pages-1.35-6
libstdc++-devel-2.96-84
console-tools-19990829-34
pciutils-2.1.8-19
semi-1.13.7-9
bind-9.1.2-0.rc1.1
samba-common-2.0.8-0.7.1
apmd-3.0final-30
XFree86-ISO8859-2-100dpi-fonts-4.0.3-11
mozilla-mail-0.8.1-5
tix-4.1.0.6-53
xscreensaver-3.32-1
usbview-1.0-1
vrfy-990522-3
libjpeg-6b-15
cmpskit-3-6
nkf-1.92-4
tar-1.13.19-4
netpbm-progs-9.9-5
statserial-1.1-20
basesystem-7.0-2
synaptics-0.1.1-1
flash-0.4.3-9
dos2unix-3.1-6
sash-3.4-8
tk-8.3.2-50
gmp-3.1.1-3
tcp_wrappers-7.6-18
control-panel-3.18-4
pnm2ppa-1.04-1
xloadimage-4.1-16
xsane-gimp-0.62-4
soundtracker-0.5.5-3
strace-4.2.20010119-3
glibc-profile-2.2.3-5
eject-2.0.4-1
libghttp-1.0.9-1
audiofile-0.2.1-1
arts-2.1.2-1
ncurses-5.2-9
emacs-el-20.7-36
gettext-0.10.37-2
openssl-0.9.6a-2
popt-1.6.3-0.12
librep-0.13.6-1
kbdconfig-1.9.12-1
apache-1.3.19-5
kudzu-0.99-1
rsh-server-0.17-2.7
SysVinit-2.78-15
tetex-latex-1.0.7-16
openssh-server-2.5.2p2-6
XFree86-100dpi-fonts-4.0.3-11
ghostscript-5.50-18
libgtop-1.0.12-1
printconf-0.2.12-1
SDL-1.2.0-1
XFree86-4.0.3-11
telnet-server-0.17-11
gnome-utils-1.4.0-1
oaf-0.6.5-1
mktemp-1.5-9
ltrace-0.3.10-5
docbook-dtd41-xml-1.0-7
ed-0.2-19
sed-3.02-9
dosfstools-2.6-1
id-utils-3.2d-6
metamail-2.7-27
playmidi-2.4-12
fwhois-1.00-12
glibc-devel-2.2.3-5
finger-0.17-9
MAKEDEV-3.1.0-15
gcc-2.96-84
a2ps-4.13b-14
filesystem-2.0.8-1
mount-2.11b-3
sgml-common-0.5-5
LPRng-3.7.4-22
XFree86-libs-4.0.3-11
netscape-communicator-4.77-1
gtk+-devel-1.2.10-1
sawfish-0.38-2

Comment 7 dunwoody 2001-05-06 16:41:42 EDT
This is a duplicate of Bug 36839.  The problem is a regression in /bin/login
sometime between util-linux-2.10s-8 and util-linux-2.11a-4.


*** This bug has been marked as a duplicate of 36839 ***

Note You need to log in before you can comment on or make changes to this bug.