Bug 39271 - /usr/sbin/makewhatis seems broken in man-1.5i-2
Summary: /usr/sbin/makewhatis seems broken in man-1.5i-2
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: man (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 40652 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-06 16:23 UTC by dunwoody
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-06 16:23:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description dunwoody 2001-05-06 16:23:29 UTC
There seems to have been a regression in /usr/sbin/makewhatis between
man-1.5h1-20 (which
works fine for me) and man-1.5i-2.  With man-1.5i-2 installed in my Rawhide
20010503 system,
the command "makewhatis -u -w" produces:

/usr/sbin/makewhatis: makewhatis7xGQza/w: No such file or directory
/usr/sbin/makewhatis: makewhatis7xGQza/w: No such file or directory
/usr/sbin/makewhatis: makewhatis7xGQza/w: No such file or directory
/usr/sbin/makewhatis: makewhatis7xGQza/w: No such file or directory
/usr/sbin/makewhatis: makewhatis7xGQza/w: No such file or directory
/usr/sbin/makewhatis: makewhatis7xGQza/w: No such file or directory
/usr/sbin/makewhatis: makewhatis7xGQza/w: No such file or directory
/usr/sbin/makewhatis: makewhatis7xGQza/w: No such file or directory

Looking at the /usr/sbin/makewhatis scripts in man-1.5h1-20 and man-1.5i-2,
there seems to have
been a change in the handling of temp files via mktemp.

Comment 1 Bernhard Rosenkraenzer 2001-05-06 17:14:10 UTC
Fixed in 1.5i-3


Comment 2 Bernhard Rosenkraenzer 2001-05-16 12:05:06 UTC
*** Bug 40652 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.