Bug 39285 - Mailman 'arch' cmd fails to create full web archive
Mailman 'arch' cmd fails to create full web archive
Status: CLOSED WONTFIX
Product: Red Hat Powertools
Classification: Retired
Component: mailman (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-06 15:42 EDT by David Woodhouse
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-13 16:14:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2001-05-06 15:42:02 EDT
Description of Problem:

A majordomo list was moved to a new Mailman installation.
The mbox-format archives of the previous list were installed into
/var/mailman/archives/private/linux-mtd.mbox/linux-mtd.mbox
The 'arch' command was invoked to rebuild the web archives.
Only the April 2001 archive was created - all previous months are missing.

See http://lists.infradead.org/pipermail/linux-mtd/ where the full archive
mbox is downloadable, and the absence of all monthly archives back to July
1999 is observed.

How Reproducible:

100%. I've tried deleting the linux-mtd list and recreating it from
scratch. I've tried using 'formail' to pass each individual mail through
'post linux-mtd' in an attempt to make Mailman happier. That resulted in
_some_ of the older mails being displayed in the archive, but very few.

Steps to Reproduce:
1. Create new list called 'linux-mtd'

2. Drop the mbox file from
http://lists.infradead.org/pipermail/linux-mtd.mbox/linux-mtd.mbox
 into the appropriate place
(/var/mailman/archives/private/linux-mtd.mbox/linux-mtd.mbox)

3. su mailman ; cd /var/mailman/archives/private ; rm -rf linux-mtd

4. ~/bin/arch linux-mtd

Actual Results:

Only April (and now May) get archived. All mails from the beginning of
April are there, although the list was created at the end of April. But
nothing earlier.

Expected Results:

All mail present in the mbox archive (dating back to July 1999) should be
present in the web archive.

Additional Information:
Comment 1 David Woodhouse 2001-08-12 12:33:47 EDT
Changing the "From " lines which separate the mails in the mailbox so that they
don't have a timezone qualifier at the end of them makes them appear in the archive.

Looks like it might actually be the Python Mailbox object which is at fault here
rather than mailman itself, or maybe the MTA delivering the mail originally -
I'm not sure if the timezone is supposed to be there.
Whether it's a workaround or a fix, it should probably be documented the passing
the archive file through sed s/^From\ \\\(.*\\\)\ [-+]..00\$/From\ \\1/ should
fix it.

Comment 2 David Woodhouse 2001-08-12 12:34:51 EDT
Still happens in the 7.2 public beta.

Changing the "From " lines which separate the mails in the mailbox so that they
don't have a timezone qualifier at the end of them makes them appear in the archive.

Looks like it might actually be the Python Mailbox object which is at fault here
rather than mailman itself, or maybe the MTA delivering the mail originally -
I'm not sure if the timezone is supposed to be there.
Whether it's a workaround or a fix, it should probably be documented the passing
the archive file through sed s/^From\ \\\(.*\\\)\ [-+]..00\$/From\ \\1/ should
fix it.
Comment 3 John Dennis 2003-03-13 16:14:41 EST
closing because this bug is very old, no one else seems to be having problems
with this and the current release of mailman is now 2.1.1

Note You need to log in before you can comment on or make changes to this bug.