Bug 39290 - rc.sysinit insists on modifying /boot every time
rc.sysinit insists on modifying /boot every time
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-06 18:42 EDT by Landon Curt Noll
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-06 18:42:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Landon Curt Noll 2001-05-06 18:42:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.17-14 i686)

Description of problem:
The rc.sysinit attempts to modify the /boot/System.map symlink
each time it is run.  This makes is annoying when one wants
to mount /boot as a read-only file system.

How reproducible:
Always

Steps to Reproduce:
1.build a system where /boot in on a separate file system
2.after the system is brought up and installed, change fstab
  so that /boot is mounted read-only
3.reboot
	

Actual Results:  On startup you see a message about attempting to modify
a read-only file system.

Expected Results:  No errors about attempts to write into /boot.
Since /boot/System.map is already a symlink
to the correct /boot/System.map-XYZZY file,
no attempt to reform the symlink should have
been made.

Additional info:

Try this symlink:

*** rc.sysinit.init	Sun May  6 14:49:19 2001
--- rc.sysinit	Sun May  6 14:49:19 2001
***************
*** 627,633 ****
  
  # Adjust symlinks as necessary in /boot to keep system services from
  # spewing messages about mismatched System maps and so on.
! if [ -L /boot/System.map -a -r /boot/System.map-`uname -r` ] ; then
  	ln -s -f System.map-`uname -r` /boot/System.map
  fi
  if [ ! -e /boot/System.map -a -r /boot/System.map-`uname -r` ] ; then
--- 627,634 ----
  
  # Adjust symlinks as necessary in /boot to keep system services from
  # spewing messages about mismatched System maps and so on.
! if [ -L /boot/System.map -a -r /boot/System.map-`uname -r` -a \
!      ! /boot/System.map -ef /boot/System.map-`uname -r` ] ; then
  	ln -s -f System.map-`uname -r` /boot/System.map
  fi
  if [ ! -e /boot/System.map -a -r /boot/System.map-`uname -r` ] ; then
Comment 1 Bill Nottingham 2001-07-10 21:18:50 EDT
Fixed in 6.01-1.

Note You need to log in before you can comment on or make changes to this bug.