Bug 39294 - unowned directories under /usr/src/linux-%{kversion}in kernel-source RPM
Summary: unowned directories under /usr/src/linux-%{kversion}in kernel-source RPM
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-07 02:52 UTC by Ganesh Sittampalam
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 02:52:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ganesh Sittampalam 2001-05-07 02:52:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; I; Linux 2.4.4 i586; Nav)

Description of problem:
In kernel 2.4.2-2 (also 2.4.3-2.14.10 from rawhide), the kernel-source
binary RPM
does not own the directories /usr/src/linux-2.4.2-2/arch and include
(despite owning directories under these). Since it does own the directory
/usr/src/linux-2.4.2-2 itself, this causes an error that it cannot delete
this directory when removing the RPM.

How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh kernel-source-foo.rpm
2. rpm -e kernel-source

	

Actual Results:  [ganesh@urchin ganesh]$ sudo rpm -hiv
/archive/redhat/7.1/RedHat/RPMS/kernel-source-2.4.2-2.i386.rpm 
Password:
Preparing...                ###########################################
[100%]
   1:kernel-source          ###########################################
[100%]
[ganesh@urchin ganesh]$ sudo rpm -e kernel-source
error: cannot remove /usr/src/linux-2.4.2 - directory not empty


Expected Results:  the final error message should not happen.

Additional info:

Comment 1 Arjan van de Ven 2001-05-10 10:38:32 UTC
Ok.. I found the cause + fixed this for our next build. Thanks for the report!


Note You need to log in before you can comment on or make changes to this bug.