Bug 393401 - Highpoint 370 detected as UDMA/44 in Fedora 8
Highpoint 370 detected as UDMA/44 in Fedora 8
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 18:01 EST by snuffboy
Modified: 2008-03-10 18:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.6.24.3-12.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 18:50:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description snuffboy 2007-11-20 18:01:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071030 Fedora/2.0.0.8-2.fc8 Firefox/2.0.0.8

Description of problem:
Highpoint 370 controller is detected only as UDMA/44 capable, although it is UDMA/100 capable.

Here is an extract from dmesg :

scsi3 : pata_hpt37x
scsi4 : pata_hpt37x
ata3: PATA max UDMA/44 cmd 0x0001bc00 ctl 0x0001c002 bmdma 0x0001cc00 irq 10
ata4: PATA max UDMA/44 cmd 0x0001c400 ctl 0x0001c802 bmdma 0x0001cc08 irq 10

I tested on 2 different mobos : Abit KT7-RAID and Abit VP6.

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-42.fc8

How reproducible:
Always


Steps to Reproduce:
1. Install Fedora 8
2. Check system log or with hdparm
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Ville Skyttä 2007-12-25 05:27:35 EST
Same story with HPT370A, Abit TH7-II RAID, kernel-2.6.23.9-85.fc8.

pata_hpt37x: HPT370A using 33MHz bus clock.
ACPI: PCI Interrupt 0000:02:06.0[A] -> GSI 18 (level, low) -> IRQ 18
scsi0 : pata_hpt37x
scsi1 : pata_hpt37x
ata1: PATA max UDMA/44 cmd 0x0001a400 ctl 0x0001a802 bmdma 0x0001b400 irq 18
ata2: PATA max UDMA/44 cmd 0x0001ac00 ctl 0x0001b002 bmdma 0x0001b408 irq 18
usb 1-1: configuration #1 chosen from 1 choice
ata1.00: ATA-7: SAMSUNG SP1614N, TM100-24, max UDMA/100
ata1.00: 312581808 sectors, multi 16: LBA48
ata1.00: configured for UDMA/44
scsi 0:0:0:0: Direct-Access     ATA      SAMSUNG SP1614N  TM10 PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] 312581808 512-byte hardware sectors (160042 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO
or FUA
sd 0:0:0:0: [sda] 312581808 512-byte hardware sectors (160042 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO
or FUA
 sda: sda1 sda2 sda3 sda4
sd 0:0:0:0: [sda] Attached SCSI disk
Comment 2 Christopher Brown 2008-02-13 18:29:34 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few weeks if there is no additional information lodged.
Comment 3 Ville Skyttä 2008-02-14 14:20:50 EST
For my part, I need the disk working as fast as it can in this particular box. 
 It's a PVR that sometimes has lots of disk activity which at those times
immediately results in problems with playback or recordings if disk I/O is not
fast enough.  All seems to be good with UDMA/100, but not with UDMA/44.

So I've had to switch the disk to another regular PIIX controller on the
motherboard which provides UDMA/100 for the same disk out of the box and have
nothing connected to the HPT370A at the moment, so I'm afraid I can't help
further right now.  Also, this is a "production" box so it's somewhat unlikely
that I will even test the HPT370A as long as the PIIX works and I don't need to
add another hard drive.
Comment 4 snuffboy 2008-02-14 14:52:38 EST
Hi Christopher,

Yes, I still have the same problem with the latest kernel (updated thru system
update two days ago).


Comment 5 Christopher Brown 2008-02-14 18:29:56 EST
(In reply to comment #4)
> Hi Christopher,
> 
> Yes, I still have the same problem with the latest kernel (updated thru system
> update two days ago).

Okay, thanks for the update. Re-assigning to the relevant maintainer...

Comment 6 Alan Cox 2008-02-15 06:43:20 EST
Already fixed in 2.6.24
Comment 7 Chuck Ebbert 2008-02-17 21:56:18 EST
2.6.24 kernel for F8 will be ready for testing soon.

Current build is:
http://koji.fedoraproject.org/koji/buildinfo?buildID=36594
Comment 8 Chuck Ebbert 2008-02-20 13:52:54 EST
2.6.24.2-7 has been submitted for testing.
Comment 9 snuffboy 2008-02-23 05:27:19 EST
Tested OK this morning with kernel 2.6.24.2-7 on Fedora 8.

Thank you all !!



[edouard@coyote ~]$ uname -r
2.6.24.2-7.fc8

Extract from dmesg :

libata version 3.00 loaded.
pata_hpt37x: HPT370 using 33MHz bus clock.
scsi0 : pata_hpt37x
scsi1 : pata_hpt37x
ata1: PATA max UDMA/100 cmd 0xb800 ctl 0xbc00 bmdma 0xc800 irq 16
ata2: PATA max UDMA/100 cmd 0xc000 ctl 0xc400 bmdma 0xc808 irq 16
ata1.00: ATA-5: WDC WD800JB-00CRA1, 17.07W17, max UDMA/100
ata1.00: 156301488 sectors, multi 16: LBA 
ata1.00: configured for UDMA/100
ata2.00: ATA-7: Maxtor 6Y160P0, YAR41BW0, max UDMA/133
ata2.00: 320173056 sectors, multi 16: LBA48 
ata2.01: ATA-7: Maxtor 6Y160P0, YAR41BW0, max UDMA/133
ata2.01: 320173056 sectors, multi 16: LBA48 
ata2.00: configured for UDMA/100
ata2.01: configured for UDMA/100


Comment 10 Chuck Ebbert 2008-02-27 15:38:52 EST
Kernel is not released yet.
Comment 11 Christopher Brown 2008-02-29 15:03:07 EST
Alan advised fix was in 2.6.24 and reporter confirmed it worked - should've
close NEXTRELEASE admittedly but I don't think I jumped the gun here...

Note You need to log in before you can comment on or make changes to this bug.