Bug 39365 - New lilo version
New lilo version
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
: 43324 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-07 10:01 EDT by Stefan Furtmayr
Modified: 2007-04-18 12:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 18:39:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix typo in lilo.h, Add MAJOR numbers for IDE7-10 (3.03 KB, patch)
2003-04-02 16:46 EST, Philip Pokorny
no flags Details | Diff
SPEC file to use patch, update source URL (6.23 KB, text/plain)
2003-04-02 16:48 EST, Philip Pokorny
no flags Details

  None (edit)
Description Stefan Furtmayr 2001-05-07 10:01:22 EDT
I think a newer lilo version should be included because the new automatic 
change feature of v21.6 is very useful for booting several primary Windows 
9X Partitions on one HDD. Also the reiserfs support was enhanched. See 
ftp://sd.dynhost.com/pub/linux/lilo/
Comment 1 Jeremy Katz 2002-06-04 02:31:03 EDT
*** Bug 43324 has been marked as a duplicate of this bug. ***
Comment 2 Philip Pokorny 2002-06-04 12:52:24 EDT
Please upgrade lilo to 21.7.5 and NOT 22.x  The interface and functionality of
the 22.x releases is very different and incompatible with some software RAID
configurations that worked under 21.x.

21.7.5 was the last version compatible with the existing lilo in Red Hat Linux
and can be found under the "obsolete" directory.
Comment 3 Jeremy Katz 2002-06-04 15:23:17 EDT
Reassigning
Comment 4 Jim Wright 2002-10-26 02:06:43 EDT
seeing how rh80 has lilo-21.4.4-20, and the lilo development site no longer has
any 21 series files available, and RH is throwing their weight behind grub, is
the answer WONTFIX?

new home at http://brun.dyndns.org/pub/linux/lilo
Comment 5 Jim Wright 2002-10-26 03:10:17 EDT
for the record, the lilo-21.4.4-14 on a rh73 system still fails to work
correctly with /dev/hdi.  for example:

% lilo 
boot = /dev/hda, map = /boot/map.0301
Added 2418-177xbig *
Added 2418-177xsmp
Added 2418-177x
Added 2418-10big
Added 2418-10smp
Added 2418-10
Added 2418-4fix
Added 2418-4big
Added 2418-4smp
Added 2418-4
Added 2418-3big
Added 2418-3smp
Added 2418-3
boot = /dev/hdc, map = /boot/map.1601
Added 2418-177xbig *
Added 2418-177xsmp
Added 2418-177x
Added 2418-10big
Added 2418-10smp
Added 2418-10
Added 2418-4fix
Added 2418-4big
Added 2418-4smp
Added 2418-4
Added 2418-3big
Added 2418-3smp
Added 2418-3
boot = /dev/hdg, map = /boot/map.2201
Added 2418-177xbig *
Added 2418-177xsmp
Added 2418-177x
Added 2418-10big
Added 2418-10smp
Added 2418-10
Added 2418-4fix
Added 2418-4big
Added 2418-4smp
Added 2418-4
Added 2418-3big
Added 2418-3smp
Added 2418-3
Fatal: Sorry, don't know how to handle device 0x3801

% cat /proc/mdstat 
Personalities : [raid1] [raid5] 
read_ahead 1024 sectors
md0 : active raid1 hda1[0] hdc1[1] hdg1[2] hdi1[3] hdk1[4]
      72192 blocks [5/5] [UUUUU]
Comment 6 Philip Pokorny 2003-04-02 16:44:55 EST
For the record, 21.4.4-20 still fails on Red Hat 8

21.7.5 is available in the obsolete sub-directory of the site mentioned above:
   http://brun.dyndns.org/pub/linux/lilo/obsolete

But if you don't want to upgrade to 21.7.5, here is a patch and spec file to fix
the problem (a typo in lilo.h)
Comment 7 Philip Pokorny 2003-04-02 16:46:48 EST
Created attachment 90853 [details]
Fix typo in lilo.h, Add MAJOR numbers for IDE7-10
Comment 8 Philip Pokorny 2003-04-02 16:48:32 EST
Created attachment 90854 [details]
SPEC file to use patch, update source URL
Comment 9 Jeremy Katz 2003-07-28 18:39:25 EDT
lilo is deprecated and will not be updated.

Note You need to log in before you can comment on or make changes to this bug.