Bug 393681 - [RFE] equivalent of apt's source and build-dep commands
[RFE] equivalent of apt's source and build-dep commands
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 01:11 EST by Pierre Ossman
Modified: 2014-01-21 18:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 01:17:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2007-11-21 01:11:44 EST
Yum has certainly improved lately, both in speed and memory footprint, so I've
switched back from apt in the hope that yum will be good enough for my needs
this time. And so far it seems to be working very well.

There are two things I badly miss from apt though. The "source" and "build-dep"
commands. For those not familiar with them, "source" is the same as "install"
but for "src" packages. It also works as a normal user though. "build-dep"
installs all the BuildRequires of the named package.

When you do a lot of small fixes here and there for different packages, these
tools are invaluable. So I'd be a very happy camper if yum got these.
Comment 1 Ignacio Vazquez-Abrams 2007-11-21 01:17:49 EST
yumdownloader and yum-builddep in yum-utils already do this.
Comment 2 James Antill 2007-11-21 01:43:27 EST
 It's worth pointing out that yumdownloader only does the download part of the
"apt-get source" UI. You then have to explode it, I have an rpmsrc alias:

rpmsrc='rpm -Uvh --define "_sourcedir `pwd`" --define "_specdir `pwd`"'

...that helps, but really it's just better to look at the Fedora repo directly
and use "cvs co <package>" and make prep.

http://docs.fedoraproject.org/documentation-guide/en_US/sn-cvs-config.html#sn-cvs-config-anon
Comment 3 Pierre Ossman 2007-11-21 08:40:24 EST
(In reply to comment #1)
> yumdownloader and yum-builddep in yum-utils already do this.

Ah, didn't know about those. Still, these would be a lot more convenient in the
main yum program.

(In reply to comment #2)
>  It's worth pointing out that yumdownloader only does the download part of the
> "apt-get source" UI. You then have to explode it, I have an rpmsrc alias:
> 

A bit of a letdown, but at least I don't have do dig up a URL manually.

(One can also just use rpm -U once you have a correctly configured .rpmmacros)

> 
> ...that helps, but really it's just better to look at the Fedora repo directly
> and use "cvs co <package>" and make prep.
> 

Assuming that fedora's repos are the only ones you need. ;)

Note You need to log in before you can comment on or make changes to this bug.