Bug 393731 - Up2date fails to install GFS and Cluster Suite components
Up2date fails to install GFS and Cluster Suite components
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: GFS-kernel (Show other bugs)
4.0
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Chris Feist
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 03:07 EST by Anand
Modified: 2010-01-11 22:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 12:30:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand 2007-11-21 03:07:23 EST
I have a set of machines that I would like to install GFS and RH Cluster Suite. 
I have been using up2date for this purpose.



When I run up2date dlm 
or 
up2date GFS-kernel 
I get the following error

********************************************************************************

[root@blr-dev105 ~]# up2date -uf

Fetching Obsoletes list for channel: rhel-x86_64-as-4...

Fetching Obsoletes list for channel: rhel-x86_64-as-4-extras...

Fetching Obsoletes list for channel: rhel-x86_64-as-4-gfs-6.1...

Fetching Obsoletes list for channel: rhel-x86_64-as-4-cluster...

Name                                    Version        Rel     
----------------------------------------------------------

All packages are currently up to date
[root@blr-dev105 ~]# up2date dlm

Fetching Obsoletes list for channel: rhel-x86_64-as-4...

Fetching Obsoletes list for channel: rhel-x86_64-as-4-extras...

Fetching Obsoletes list for channel: rhel-x86_64-as-4-gfs-6.1...

Fetching Obsoletes list for channel: rhel-x86_64-as-4-cluster...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
dlm                                     1.0.3          1                 x86_64


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
cman-kernel  2.6.9-50.2.0.6              requires /lib/modules/2.6.9-55.0.12.EL
dlm-kernel  2.6.9-46.16.0.12             requires /lib/modules/2.6.9-55.0.12.EL


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------
cman-kernel-2.6.9-50.2.0.6.x86_64       cman-1.0.17-0                          
cman-kernel-modules                     
dlm-kernel-2.6.9-46.16.0.12.x86_64      dlm-1.0.3-1                            
dlm-kernel-module

*******************************************************************************

And then when I try to run up2date lvm2-cluster it reports to me saying ... 
[root@blr-dev105 ~]# up2date lvm2-cluster lvm2

Fetching Obsoletes list for channel: rhel-x86_64-as-4...

Fetching Obsoletes list for channel: rhel-x86_64-as-4-extras...

Fetching Obsoletes list for channel: rhel-x86_64-as-4-gfs-6.1...

Fetching Obsoletes list for channel: rhel-x86_64-as-4-cluster...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
lvm2-cluster                            2.02.21        7.el4             x86_64


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
lvm2-2.02.27-2.el4                       conflicts with lvm2-cluster < 2.02.27 


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------



Looks like up2date there are strange rpm dependencies that are not completely
being resolved properly; is there anyway I can fix this?
Comment 1 Steve Whitehouse 2008-12-10 11:46:41 EST
Anand, can you confirm whether this issue is solved or not? If so, please close this bug.
Comment 2 Chris Feist 2008-12-10 12:30:25 EST
Closing this bug as this issue has been resolved (for a long time) with the latest 4.7 packages).

Note You need to log in before you can comment on or make changes to this bug.