Bug 393951 - unversioned obsoletes and provides
Summary: unversioned obsoletes and provides
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnuplot   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-21 10:52 UTC by Florian La Roche
Modified: 2008-01-29 13:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 13:02:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file with versioning obsoletes and remove one provides (1.02 KB, patch)
2007-11-21 11:24 UTC, Patrice Dumas
no flags Details | Diff

Description Florian La Roche 2007-11-21 10:52:14 UTC
Description of problem:

Current gnuplot has the following in the spec file:

%package -n emacs-%{name}
Provides: gnuplot-emacs
Obsoletes: gnuplot-emacs

%package -n emacs-%{name}-el
Provides: gnuplot-emacs
Obsoletes: gnuplot-emacs


This adds obsoletes between the above two packages. Better would be
to only have the obsoletes once for the emacs-gnuplot rpm, but not add
it for the -el subrpm.


regards,

Florian La Roche



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Patrice Dumas 2007-11-21 11:22:24 UTC
The Obsoletes and requires should be versioned, but I can't see what's 
wrong with having 2 obsoletes. This ensures that both packages 
are installed if somebody had gnuplot-emacs installed. Since emacs-gnuplot-el
requires emacs-gnuplot, the obsoletes in emacs-gnuplot is a bit 
superfluous, but since it is more logical I think it should be kept.

Having both packages Provides gnuplot-emacs seems more dubious to me.

Comment 2 Patrice Dumas 2007-11-21 11:24:49 UTC
Created attachment 265861 [details]
spec file with versioning obsoletes and remove one provides

This patch versions obsoletes and provides.

It also remove the Provides: gnuplot-emacs from the -el
subpackage.

Comment 3 Stepan Kasal 2007-11-23 13:26:01 UTC
Yes, the patch looks ok.
See also
http://fedoraproject.org/wiki/Packaging/NamingGuidelines#head-3cfc1ea19d28975faad9d56f70a6ae55661d3c3d
(And I'm changing the summary line.)

Comment 4 Florian La Roche 2007-12-14 15:47:57 UTC
Hello,

can this now go into rawhide?

regards,

Florian La Roche


Comment 5 Patrice Dumas 2008-01-28 19:02:17 UTC
Ping?

Comment 6 Ivana Varekova 2008-01-29 13:02:26 UTC
Thanks. Fixed in gnuplot-4.2.2-9.fc9.


Note You need to log in before you can comment on or make changes to this bug.