Bug 393991 - SELinux is preventing /usr/lib/cups/daemon/cups-driverd (cupsd_t) "search" to (dosfs_t).
SELinux is preventing /usr/lib/cups/daemon/cups-driverd (cupsd_t) "search" to...
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-21 06:21 EST by Nataraj
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-22 06:32:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nataraj 2007-11-21 06:21:21 EST
Description of problem:
SELinux denied access requested by /usr/lib/cups/daemon/cups-driverd. It is not
expected that this access is required by /usr/lib/cups/daemon/cups-driverd and
this access may signal an intrusion attempt. It is also possible that the
specific version or configuration of the application is causing it to require
additional access.

Version-Release number of selected component (if applicable):
cups-1.3.4-2.fc8 [application]

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Tim Waugh 2007-11-21 09:09:35 EST
Thanks for the report.  I'd like some additional information:

1. Can you get this to occur on demand?  If so, how?

2. What does 'mount' say?
Comment 2 Nataraj 2007-11-21 11:35:32 EST
I was using gnome print manager in FC 8 X86_64 OS to add a new printer. When
ever I tried, it gave this error in error report of SELinux.

I did not get the second question. I cannot try typing 'mount' in the terminal
now because I tried experimenting on removing all the SELInux files in the
system as suggested by some one. Since then it is not booting to the kernel. It
shows the following while booting:
/bin/sh: ro: No such file or directory
kernel panic - not syncing: Attempted to kill init!

I am quite sorry.

Thanks for your serious efforts.

Comment 3 Nataraj 2007-11-21 11:40:06 EST
I am now thinking of reintalling the OS as I could not find any fix in the net.

I tried recovering using the Rescue CD that came with FC 8 64 bit version. But
it just takes me to the shell/single user mode. I donot know what files are
missing/needed to fix it. 

Any suggestions to recover? 

Thanks in advance.
Comment 4 Tim Waugh 2007-11-22 06:32:49 EST
Not in this bug reporting forum -- try the fedora-list mailing list.

Note You need to log in before you can comment on or make changes to this bug.