Bug 394 - kernel compilation yields wrong kernel ID
kernel compilation yields wrong kernel ID
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-11 17:59 EST by djaeger
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-13 18:02:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description djaeger 1998-12-11 17:59:28 EST
I need to recompile my kernel since I have dual processor
machines. (Frankly, I think this should be supported without
recompilation by now).

I made a new installation of RedHat 5.2 and added the
kernel source and kernel header patches version 2.0.36-1.

I ran xconfig and edit the Makefile to enable SMP. After
compilation (including modules and modules_install) and
updating lilo my computer now boots as RedHat 5.2
kernel revision 2.0.0 instead of 2.0.36 (as before). Since
the modules get installed as 2.0.36 no modules are
available.

Fix:  I need help on this one. Thanks.
Comment 1 David Lawrence 1998-12-13 18:02:59 EST
We are considering for upcoming releases the possibility of shipping
an additional kernel enable for SMP support but no decision has been
made as of yet. With the upcoming release of 2.2 kernel this should be
an easier process.

Note You need to log in before you can comment on or make changes to this bug.