Bug 39405 - No swapon in rescue mode
No swapon in rescue mode
Status: CLOSED DUPLICATE of bug 39403
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-07 11:29 EDT by Ed Bailey
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-27 14:12:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Bailey 2001-05-07 11:29:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; 0.8.1)
Gecko/20010430

Description of problem:
Although it is possible to create a swap partition, and to run mkswap
against it, swapon is not available in rescue mode.  Sometimes it is
necessary to enable swap manually while in rescue mode; this makes it kind
of difficult to do so... :-)

How reproducible:
Always

Steps to Reproduce:
1.Boot from the 7.1 CD #1

2.Type 'linux rescue' at the boot prompt

3.Once you get a shell prompt, look for swapon
	

Additional info:

It may be that rescue mode calls swapon() as part of anaconda's
initialization.  If this is so, the logic that is used to do this should be
modified to not depend on finding a valid fstab to find the swap partitions
to be enabled.

(This is conjecture on my part, but my system at the time did not have a
valid root filesystem, and anaconda told me that I had "no linux
partitions" when I did have several...)

I'm calling this normal severity, as there is a workaround (assuming
network or SneakerNet connectivity)...
Comment 1 Michael Fulbright 2001-06-27 14:13:30 EDT

*** This bug has been marked as a duplicate of 39403 ***

Note You need to log in before you can comment on or make changes to this bug.