Bug 394451 - system-config-display ignores hsync and vsync values
system-config-display ignores hsync and vsync values
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-display (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 11:02 EST by Patrick C. F. Ernzer
Modified: 2012-04-17 15:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 15:59:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2007-11-21 11:02:32 EST
Description of problem:
I have an IBM Blade Center here where the resolution of the display on the KVM
is higher than what the system can redirect remotely. So while all the
autoprobing gives me a nice local console, the IBM supplied remote console just
gives me a black screen with a message to the effect of 'screen resolution out
of bounds'

Now my problem lies with working around this.

system-config-display --help seems to be the only documentation to the tool but
should be enough

How reproducible:
always

Affected version:
system-config-display-1.0.48-2.el5

Steps to Reproduce:
1. telinit 3
2. rm /etc/X11/xorg.conf (just to be sure all is clean)
3. # system-config-display --reconfig  --set-vsync="40.0-70.0"
--set-hsync="31.5-48.5"
4. cat /etc/X11/xorg.conf

Actual results:
I get the following xorg.conf:
# Xorg configuration created by system-config-display

Section "ServerLayout"
       Identifier     "Default Layout"
       Screen      0  "Screen0" 0 0
       InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
       Identifier  "Keyboard0"
       Driver      "kbd"
       Option      "XkbModel" "pc105"
       Option      "XkbLayout" "us"
EndSection

Section "Device"
       Identifier  "Videocard0"
       Driver      "radeon"
EndSection

Section "Screen"
       Identifier "Screen0"
       Device     "Videocard0"
       DefaultDepth     24
       SubSection "Display"
               Viewport   0 0
               Depth     24
       EndSubSection
EndSection

Expected results:
If I nail down options by hand I expect them to end up in the config

Additional info:
Maybe I just fat-fingered something here, would be nice if there was a bit more
documentation.

FWIW: running
# system-config-display --reconfig  --set-vsync="40.0-70.0"
--set-hsync="31.5-48.5" --set-resolution="1024x768"
I get

# Xorg configuration created by system-config-display

Section "ServerLayout"
       Identifier     "Default Layout"
       Screen      0  "Screen0" 0 0
       InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
       Identifier  "Keyboard0"
       Driver      "kbd"
       Option      "XkbModel" "pc105"
       Option      "XkbLayout" "us"
EndSection

Section "Device"
       Identifier  "Videocard0"
       Driver      "radeon"
EndSection

Section "Screen"
       Identifier "Screen0"
       Device     "Videocard0"
       DefaultDepth     24
       SubSection "Display"
               Viewport   0 0
               Depth     24
               Modes    "1024x768" "800x600" "640x480"
       EndSubSection
EndSection

still no hsync or vsync values.


Small note for other BladeCenter users reading this; specifying --set-driver=vesa
makes your blade center KVM redirect work. This bug is about the tool not taking
the values it is fed, not about BC specifically, I just ran into it on that
hardware.
Comment 1 Matěj Cepl 2008-01-31 11:33:26 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server log file (/var/log/Xorg.*.log) to the bug report as
individual uncompressed file attachment using the bugzilla file attachment link
below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Patrick C. F. Ernzer 2008-01-31 12:26:53 EST
Sorry, the system in question is currently used by another user.

I do not understand why you want me to try autoconfig when my bugreport is about
s-c-display ignoring a parameter it claims to support.
Comment 3 Matěj Cepl 2008-01-31 16:38:18 EST
I am sorry, I missed the note in the last paragraph. Sure, passing the bug to
developers.
Comment 4 Matěj Cepl 2008-01-31 16:49:38 EST
This looks like having Fedora 8 duplicate in bug 430501
Comment 6 Adam Jackson 2012-04-17 15:59:29 EDT
* Mon Oct 31 2011 Adam Jackson <ajax@redhat.com> 0.41.1-10¬
- rhpxl-monitor.patch: Create a Monitor section if needed (--set-?sync¬
  passed but no existing Monitor section) (#429949)¬

This should be fixed in current updates for rhpxl and pyxf86config.

Note You need to log in before you can comment on or make changes to this bug.