Bug 394541 - API call show only deprecated items
API call show only deprecated items
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Devan Goodwin
Brandon Perkins
:
Depends On:
Blocks: 248642
  Show dependency treegraph
 
Reported: 2007-11-21 11:39 EST by Miroslav Suchý
Modified: 2008-04-02 16:58 EDT (History)
0 users

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 16:58:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2007-11-21 11:39:04 EST
Description of problem:
I have latest sat (510-26) and call api listAllPackages (see script on bottom)
and it return just that deprecated items package_*.

Version-Release number of selected component (if applicable):
510-26
api.getVersion return 5.1.0 Java

How reproducible:
deterministic

Steps to Reproduce:
1. run attached script

  
Actual results:
package_last_modified, package_epoch, package_name, package_id, package_release,
package_version, package_arch_label
package_last_modified, package_epoch, package_name, package_id, package_release,
package_version, package_arch_label
package_last_modified, package_epoch, package_name, package_id, package_release,
package_version, package_arch_label
package_last_modified, package_epoch, package_name, package_id, package_release,
package_version, package_arch_label
.....

Expected results:
name, version,.....,package_last_modified, package_epoch,...
....

Additional info:
#!/usr/bin/perl
use Frontier::Client;
my $HOST = 'xen88.englab.brq.redhat.com';
my $user = 'admin';
my $pass = 'XXXXXXX';
my $client = new Frontier::Client(url => "http://$HOST/rpc/api");
my $session = $client->call('auth.login',$user, $pass);
my $pkgs = $client->call('channel.software.listAllPackages', $session,
'redhat-rhn-proxy-5.0-as-i386-4');
foreach my $pkg (@$pkgs) {
   print join(', ', keys(%{$pkg})),"\n";
}
$client->call('auth.logout', $session);
Comment 1 Devan Goodwin 2007-11-28 11:50:51 EST
Additional aliases were added to most package queries when the decision was made
to deprecate the package_ fields, looks like this one was missed.

Sending        code/src/com/redhat/rhn/common/db/datasource/xml/Package_queries.xml
Sending        code/src/com/redhat/rhn/manager/channel/ChannelManager.java
Transmitting file data ..
Committed revision 134268.
Comment 2 Brandon Perkins 2007-12-21 15:46:32 EST
Verified.
Comment 3 Brandon Perkins 2008-03-21 15:09:21 EDT
Release Pending.
Comment 4 Brandon Perkins 2008-04-02 16:58:36 EDT
API call Enhancements for 5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.