Bug 39464 - Starting new programs doesn't work, running programs keep working OK
Starting new programs doesn't work, running programs keep working OK
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-07 16:00 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-11 08:53:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The /var/log/messages file might be usefull (20.73 KB, text/plain)
2001-05-07 16:08 EDT, Need Real Name
no flags Details
up2date log, error occured both before and after updating (I rebooted after updating) (6.74 KB, text/plain)
2001-05-07 16:11 EDT, Need Real Name
no flags Details
X server log gzipped (5.27 KB, application/octet-stream)
2001-06-05 22:35 EDT, j. alan eldridge
no flags Details

  None (edit)
Description Need Real Name 2001-05-07 16:00:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
I am not sure if this is a XFree bug. I am running on a 266Mhz Pentium II
MMX laptop with 128Mb memory. After a few minutes running gnome or KDE I
cannot start any new programs anymore. I can click whatever I want, no new
windows (for the programs start) appear. The Gnome menu ('start button')
does work. The mouse moves OK. Already running programs respond OK.

How reproducible:
Always (for me)

Steps to Reproduce:
1. Reboot
2. Start window manager, gnome or KDE
3. Start a program, e.g. Netscape
4. Browse around.
5. After a few minutes, try to start a program, e.g. a new terminal
(emulation program)
	

Actual Results:  The terminal emulation program doesn't start

Expected Results:  Program should start

Additional info:

The same error occurs in both Gnome and KDE. I think this is a high
severity error because the laptop is unusable until reboot.
Comment 1 Need Real Name 2001-05-07 16:08:09 EDT
Created attachment 17586 [details]
The /var/log/messages file might be usefull
Comment 2 Need Real Name 2001-05-07 16:11:18 EDT
Created attachment 17587 [details]
up2date log, error occured both before and after updating (I rebooted after updating)
Comment 3 Mike A. Harris 2001-05-09 20:05:28 EDT
This is likely a local configuration problem of some kind I believe,
perhaps a conflict with some software you are using.  Attach your
XFree86 server log from after you've had a problem.  Also, your
XF86Config-4 file.
Comment 4 Mike A. Harris 2001-05-09 20:10:01 EDT
Also, if you boot graphical login, change to a non graphical login
by changing: initdefault:5 to initdefault:3 in /etc/inittab, then reboot.

Start X with:

startx > X.log 2>&1

Then wait until you experience the problem, then kill X, start it up again
with just "startx" and attach the X.log file to the bug report.
Comment 5 j. alan eldridge 2001-06-05 22:33:59 EDT
Interesting. I've been seeing similar behavior. At first I thought it was KDE 
2.2alpha fscking up in strange and wondrous ways. But ...

If you strace one of the clients, you see that it sends the "MAGIC-COOKIE" 
message to X, it gets back its response, and then, next read, it gets an EOF 
on the socket to X. This condition does not always seem to be permanent; it 
sometimes spontaeously reverts to working behavior. 

I just saw another message tonight, from Xv, that prompted me to come here and 
look:

 XIO:  fatal IO error 105 (No buffer space available) on X server ":0.0"
      after 1330041 requests (1323083 known processed) with 743 events 
remaining.

Ouch. Nothing looks terribly interesting in the log, but will be attached 
after this comment is added.



Comment 6 j. alan eldridge 2001-06-05 22:35:01 EDT
Created attachment 20392 [details]
X server log gzipped
Comment 7 j. alan eldridge 2001-06-05 22:38:51 EDT
Ooh. This is unsavory. I've got *thousands* of these in my /var/log/messages 
over the last couple of hours:


Jun  5 22:09:34 wwweasel kernel: __alloc_pages: 2-order allocation failed.
Jun  5 22:09:34 wwweasel kernel: __alloc_pages: 3-order allocation failed.
Jun  5 22:09:34 wwweasel kernel: __alloc_pages: 3-order allocation failed.
Jun  5 22:09:34 wwweasel kernel: __alloc_pages: 2-order allocation failed.
Jun  5 22:09:34 wwweasel kernel: __alloc_pages: 3-order allocation failed.


This can't be good, huh?

Comment 8 Mike A. Harris 2002-02-11 08:53:34 EST
Ben.Verloop@jnc.nl, please attach X server log and config file uncompressed as
file attachments using bugzilla's link below.
Comment 9 Mike A. Harris 2002-03-14 14:29:26 EST
Closing bug.  Please reopen after attaching requested information if
problem persists.

Note You need to log in before you can comment on or make changes to this bug.