Bug 39465 - disabling SSL in apacheconf still leaves SSL enabled
disabling SSL in apacheconf still leaves SSL enabled
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-httpd (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-07 16:16 EDT by Gerald Britton
Modified: 2015-03-04 20:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 10:17:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Britton 2001-05-07 16:16:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-SGI_XFS_1.0smp i686; en-US;
rv:0.9+) Gecko/20010503

Description of problem:
SSL is disabled in all virtual hosts and all defaults, but the
webserver still listens on the https port and responds to requests
there with the default dummy certificate.

How reproducible:
Always

Steps to Reproduce:
1.Disable all SSL entries in virtual hosts.
2.Restart httpd
	

Additional info:
Comment 1 Phil Knirsch 2003-11-27 06:23:27 EST
Reassinging to r-c-h and myself.

Read ya, Phil
Comment 2 Jack Tanner 2004-02-03 18:20:53 EST
I wonder if this is related...

I think the vanilla ssl.conf contains Listen 443. Since ssl.conf is
INCLUDEd in httpd.conf by default, httpd will bind to 443 and exhibit
this behavior.

Moreover, the entry in ssl.conf will cause a conflict if you should
define another 443 listener under the Main tab. (This is obvious in
hindsight.)
Comment 3 Phil Knirsch 2004-10-14 10:17:32 EDT
Should be fixed now in latest rawhide build.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.