Bug 395361 - hts traceback on a T61
hts traceback on a T61
Status: CLOSED DUPLICATE of bug 395491
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
i386 Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 04:04 EST by Joachim Schröder
Modified: 2008-07-16 17:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 10:51:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Schröder 2007-11-22 04:04:10 EST
Description of problem:
on a T61 with RHEL 5.1, running hts results in a traceback:

hts plan
hts server start

[root@rhel5-t61 ~]# hts certify --mode auto
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
running usb on /org/freedesktop/Hal/devices/computer
mkdir -p /tmp/hts-usb-rM4oed/mnt/tests/HTS/hts/usb
cp -a runtest.sh usb.py Makefile /tmp/hts-usb-rM4oed/mnt/tests/HTS/hts/usb
install -m 0755 runtest.sh /tmp/hts-usb-rM4oed/mnt/tests/HTS/hts/usb
make OUTPUTFILE=/var/log/hts/runs/1/usb/output.log RUNMODE=auto 
UDI=/org/freedesktop/Hal/devices/computer DEVICE= TESTSERVER=unknown run
chmod a+x ./runtest.sh ./usb.py
./runtest.sh
/tmp/hts-usb-rM4oed/mnt/tests/HTS/hts/usb/usb.py
Running ./usb.py:
USB test:
USB Hub Interface appears to be plugged into bus 1 port 0
USB Hub Interface appears to be plugged into bus 2 port 0
USB Hub Interface appears to be plugged into bus 6 port 0
USB Hub Interface appears to be plugged into bus 3 port 0
USB HID Interface appears to be plugged into bus 3 port 1
M-UV69a Optical Wheel Mouse appears to be plugged into bus 3 port 1
USB Hub Interface appears to be plugged into bus 4 port 0
USB Vendor Specific Interface appears to be plugged into bus 4 port 1
Mini Card appears to be plugged into bus 4 port 1
USB Hub Interface appears to be plugged into bus 5 port 0
USB Hub Interface appears to be plugged into bus 7 port 0
Test Mode: auto, USB Sockets NOT TESTED!
...finished running ./usb.py, exit code=0
recovered exit code=0
hts-report-result /HTS/hts/usb PASS /var/log/hts/runs/1/usb/output.log
Traceback (most recent call last):
  File "/usr/bin/hts", line 122, in ?
    success = hts.do(args)
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 68, in do
    return self.doCertify()
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 314, in 
doCertify
    self.saveSystemLog(test, run)
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 561, in 
saveSystemLog
    if l.find(marker_str + "begin") >= 0:
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 109: 
ordinal not in range(128)

How reproducible:
just install RHEL 5.1 on a T61, install hts and run the plan, start and 
certify commands with hts as described above.

Actual results:
traceback

Expected results:
run the cert suite
Comment 1 Greg Nichols 2007-11-26 09:49:24 EST
What locale is this system set to?
Comment 2 Greg Nichols 2007-11-26 10:48:34 EST
Also, what version and release of HTS was used?
Comment 3 Greg Nichols 2007-11-27 10:51:40 EST

*** This bug has been marked as a duplicate of 395491 ***

Note You need to log in before you can comment on or make changes to this bug.