Bug 395431 - s-c-ki crashes (may be in code, related with MBR)
s-c-ki crashes (may be in code, related with MBR)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 406861 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 04:44 EST by Anton Guda
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-23 17:42:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anton Guda 2007-11-22 04:44:08 EST
Description of problem:
system-config-kickstart give traceback on startup.

Version-Release number of selected component (if applicable):

system-config-kickstart-2.7.13-1
pykickstart-1.22-1


How reproducible:
always

Steps to Reproduce:
1. system-config-kickstart
2. wait for repositories (here may be another bug)

  
Actual results:
traceback and exit

Expected results:
work w/o traceback

Additional info:

traceback
Component: system-config-kickstart
Summary: TBae86c3ff partition.py:281:applyKickstart:AttributeError: F9_ZeroMbr 
instance has no attribute 'zerombr'

Traceback (most recent call last):
  File "/usr/bin/system-config-kickstart", line 83, in <module>
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 180, in 
__init__
    self.applyKickstart()
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 333, in 
applyKickstart
    self.partition_class.applyKickstart()
  File "/usr/share/system-config-kickstart/partition.py", line 281, in 
applyKickstart
    if self.ks.zerombr.zerombr:
AttributeError: F9_ZeroMbr instance has no attribute 'zerombr'

Local variables in innermost frame:
self: <partition.partition instance at 0x99dfacc>


P.S. it may be a typo in 
/usr/share/system-config-kickstart/partition.py +281
zerombr.zerombr
Comment 1 Chris Lumens 2007-11-23 17:42:43 EST
This will be fixed in the next build of pykickstart.
Comment 2 Chris Lumens 2007-11-30 14:32:20 EST
*** Bug 406861 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.