Bug 39545 - top shows 0k shared since 2.2.19-6.2.1
top shows 0k shared since 2.2.19-6.2.1
Status: CLOSED DUPLICATE of bug 38094
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-08 00:02 EDT by thompson
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-08 11:18:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description thompson 2001-05-08 00:02:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.1 i686)

Description of problem:
86 processes: 83 sleeping, 3 running, 0 zombie, 0 stopped
CPU states:  3.2% user,  1.1% system, 95.3% nice,  0.1% idle
Mem:   130404K av,   91616K used,   38788K free,       0K shrd,    4260K
buff
Swap:  128512K av,   20336K used,  108176K free                   43252K
cached

  PID USER     PRI  NI  SIZE  RSS SHARE STAT  LIB %CPU %MEM   TIME COMMAND
  835 folding   20  19  4640 2156  1160 R N     0 97.1  1.6 697:44
fahclient
 4124 thompson   1   0   872  872   656 R       0  1.9  0.6   0:00 top
 3955 root       0   0 63024  61M  1768 S       0  0.9 48.3   0:11 X
rpm -qif /usr/bin/top
Name        : procps                       Relocations: (not relocateable)
Version     : 2.0.6                             Vendor: Red Hat, Inc.
Release     : 5                             Build Date: Tue 07 Mar 2000
12:03:30 PM CST
Install date: Fri 03 Nov 2000 04:20:26 PM CST      Build Host:
porky.devel.redhat.com
Group       : Applications/System           Source RPM:
procps-2.0.6-5.src.rpm
Size        : 288372                           License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Utilities for monitoring your system and processes on your
system.



How reproducible:
Always

Steps to Reproduce:
1. run top
2.
3.
	

Additional info:
Comment 1 thompson 2001-05-08 11:08:56 EDT
"free" command appears to have the same problem.
Comment 2 thompson 2001-05-08 11:17:58 EDT
Seems to stem from /proc/meminfo being incorrect....
Comment 3 giulioo 2001-05-08 17:36:23 EDT
It seems this is expected behavior, at least in the 2.2.x RedHat patched kernel.
2.4.x dropped shared memory reporting for performance reasons.



*** This bug has been marked as a duplicate of 38094 ***

Note You need to log in before you can comment on or make changes to this bug.