Bug 395601 - check_log doesn't have correct paths for diff and tail
Summary: check_log doesn't have correct paths for diff and tail
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nagios-plugins   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mike McGrath
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-22 12:37 UTC by Matt Dainty
Modified: 2008-04-09 19:22 UTC (History)
1 user (show)

Fixed In Version: 1.4.11-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 19:22:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the check_log diff and tail paths (372 bytes, patch)
2007-11-22 12:37 UTC, Matt Dainty
no flags Details | Diff

Description Matt Dainty 2007-11-22 12:37:02 UTC
Description of problem:

The check_log plugin doesn't have the correct paths for diff and tail so the
plugin fails to work. The plugin tries to use /bin/diff and /bin/tail whereas on
my Fedora 7 box, these are /usr/bin/diff and /usr/bin/tail

Version-Release number of selected component (if applicable):

1.4.8-1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I fixed this by adding the attached patch to the src.rpm and rebuilding.

Comment 1 Matt Dainty 2007-11-22 12:37:02 UTC
Created attachment 266801 [details]
Patch to fix the check_log diff and tail paths

Comment 2 Mike McGrath 2008-04-09 19:22:54 UTC
Thanks, looks like upstream got to this one already.  Sorry it took so long :-/


Note You need to log in before you can comment on or make changes to this bug.