Bug 395951 - kopete crashes when it tries to connect to MSN
kopete crashes when it tries to connect to MSN
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 12:49 EST by Jeroen Beerstra
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-25 10:15:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeroen Beerstra 2007-11-22 12:49:17 EST
Description of problem: Kopete crashes as soon as you try to connect to MSN


Version-Release number of selected component (if applicable):

kdenetwork-3.5.8-9.fc7

How reproducible:

Connect to MSN with kopete


Steps to Reproduce:
1. Start kopete
2. Connect to MSN or create a new MSN profile
3. Kopete crashes
  
Actual results:

Kopete crashes

Expected results:

Kopete should just connect to MSN like it did before.

Additional info:

(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 46912555503712 (LWP 6061)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5  0x00002aaaac0cc910 in KConfigBase::writeEntry ()
   from /usr/lib64/libkdecore.so.4
#6  0x00002aaaac0cccca in KConfigBase::writeEntry ()
   from /usr/lib64/libkdecore.so.4
#7  0x00002aaab38135ce in MSNEditAccountWidget::apply ()
   from /usr/lib64/libkopete_msn_shared.so.0
#8  0x00000000004437f0 in ?? ()
#9  0x0000003fd2ebc1f9 in QDialog::qt_invoke ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#10 0x0000003fd2ebf39d in QWizard::qt_invoke ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#11 0x00002aaaabb4ee09 in KWizard::qt_invoke () from /usr/lib64/libkdeui.so.4
#12 0x000000000044355d in ?? ()
#13 0x0000003fd2b62a19 in QObject::activate_signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#14 0x0000003fd2b63700 in QObject::activate_signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#15 0x0000003fd2b99a29 in QWidget::event ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#16 0x0000003fd2b019b5 in QApplication::internalNotify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#17 0x0000003fd2b02e40 in QApplication::notify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#18 0x00002aaaac0ffbb8 in KApplication::notify ()
   from /usr/lib64/libkdecore.so.4
#19 0x0000003fd2aa0faa in QETWidget::translateMouseEvent ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#20 0x0000003fd2aa0395 in QApplication::x11ProcessEvent ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#21 0x0000003fd2ab0284 in QEventLoop::processEvents ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#22 0x0000003fd2b19117 in QEventLoop::enterLoop ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#23 0x0000003fd2ce4d2b in QDialog::exec ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#24 0x00000000004337e3 in QWidget::setUpdatesEnabled ()
#25 0x00000000004343c0 in QWidget::setUpdatesEnabled ()
#26 0x0000003fd2b62a19 in QObject::activate_signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#27 0x0000003fd2e99bf4 in QSignal::signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#28 0x0000003fd2b7de05 in QSignal::activate ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#29 0x0000003fd2b85db8 in QSingleShotTimer::event ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#30 0x0000003fd2b019b5 in QApplication::internalNotify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#31 0x0000003fd2b02c60 in QApplication::notify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#32 0x00002aaaac0ffbb8 in KApplication::notify ()
   from /usr/lib64/libkdecore.so.4
#33 0x0000003fd2af6bcc in QEventLoop::activateTimers ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#34 0x0000003fd2ab02e1 in QEventLoop::processEvents ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#35 0x0000003fd2b19117 in QEventLoop::enterLoop ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#36 0x0000003fd2b18ff2 in QEventLoop::exec ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#37 0x000000000043da2a in QWidget::setUpdatesEnabled ()
#38 0x0000003e2c01dab4 in __libc_start_main () from /lib64/libc.so.6
#39 0x000000000042e709 in QWidget::setUpdatesEnabled ()
#40 0x00007fff7af2b458 in ?? ()
#41 0x0000000000000000 in ?? ()
Comment 1 Rex Dieter 2007-11-22 13:48:35 EST
Odd, WORKSFORME, I use it almost every day.

I'll go try resetting things, and try setting up a new user, and see if I can
reproduce this.


Comment 2 Jeroen Beerstra 2007-11-23 06:53:45 EST
I know, somehow it stopped working all of a sudden, this was before the upgrade
to 3.5.8. However I did delete kopeterc, and only kopeterc. When I also delete
.kde/share/apps/kopete it doesn't crash, however it still can't connect to MSN
which was my original problem. I get this when I run kopete inside a terminal:

MNG error 1029: Chunk out of sequence; chunk TERM; subcode 0:0
MNG error 1029: Chunk out of sequence; chunk TERM; subcode 0:0
MNG error 1029: Chunk out of sequence; chunk TERM; subcode 0:0
MNG error 1029: Chunk out of sequence; chunk TERM; subcode 0:0
MNG error 1029: Chunk out of sequence; chunk TERM; subcode 0:0
MNG error 1029: Chunk out of sequence; chunk TERM; subcode 0:0
MNG error 1029: Chunk out of sequence; chunk TERM; subcode 0:0
MNG error 1029: Chunk out of sequence; chunk TERM; subcode 0:0

From the users perspective it tries to connect a couple of seconds and then just
stops, no errors, nothing.

When I google on this error I found this:
https://bugs.launchpad.net/ubuntu/+source/kopete/+bug/153670

Which describes a similar problem on Ubuntu and was the reason for this bug
report in the first place. Perhaps this helps.
Comment 3 Jeroen Beerstra 2007-11-25 10:15:44 EST
Ok me confused, today everything works again. AFAIK nothing changed, but today I
can connect to MSN just like before. I guess there were some problems/changes
with MSN itself, one would expect some kind of error message from Kopete in such
a case which wasn't the case, but as long as it works I guess.

Will reopen/submit a new bug report if I have any more problems.

Note You need to log in before you can comment on or make changes to this bug.