Bug 396051 - Suspend/resume not working
Suspend/resume not working
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 14:33 EST by Matthias Runge
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 02:07:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2007-11-22 14:33:08 EST
Description of problem:
Notebook suspends find, but never comes up really.

Version-Release number of selected component (if applicable):
pm-utils-0.99.4-6.fc8
kernel-2.6.23.1-49.fc8


How reproducible:
every time

Steps to Reproduce:
1. issue pm-suspend
2. hit the wakeup-key
3.
  
Actual results:
suspend works fine, wakeup does not. Screen remains black, sometimes the
caps-lock keeps flashing.

Expected results:
system wakes up fine. 

Additional info:
System is a T43 with an ATI X300.

echo "1" > /sys/power/pm_trace

syslog (interesting section, some lengthy, sorry!) Full suspend/resume cycle.
Mar 21 05:13:10 sofja kernel: Stopping tasks ... done.
Mar 21 05:13:10 sofja kernel: Suspending console(s)
Mar 21 05:13:10 sofja kernel: sd 0:0:0:0: [sda] Synchronizing SCSI cache
Mar 21 05:13:10 sofja kernel: sd 0:0:0:0: [sda] Stopping disk
Mar 21 05:13:10 sofja kernel: pnp: Device 00:0a disabled.
Mar 21 05:13:10 sofja kernel: pnp: Device 00:09 disabled.
Mar 21 05:13:10 sofja kernel: ACPI: PCI interrupt for device 0000:0b:02.0 disabl
ed
Mar 21 05:13:10 sofja kernel: ACPI: PCI interrupt for device 0000:00:1e.3 disabl
ed
Mar 21 05:13:10 sofja kernel: ACPI: PCI interrupt for device 0000:00:1e.2 disabl
ed
Mar 21 05:13:10 sofja kernel: ACPI: PCI interrupt for device 0000:00:1d.7 disabl
ed
Mar 21 05:13:10 sofja kernel: ACPI: PCI interrupt for device 0000:00:1d.3 disabl
ed
Mar 21 05:13:10 sofja kernel: ACPI: PCI interrupt for device 0000:00:1d.2 disabl
ed
Mar 21 05:13:10 sofja kernel: ACPI: PCI interrupt for device 0000:00:1d.1 disabl
ed
Mar 21 05:13:10 sofja kernel: ACPI: PCI interrupt for device 0000:00:1d.0 disabl
ed
Mar 21 05:13:10 sofja kernel: Disabling non-boot CPUs ...
Mar 21 05:13:10 sofja kernel: Intel machine check architecture supported.
Mar 21 05:13:10 sofja kernel: Intel machine check reporting enabled on CPU#0.
Mar 21 05:13:10 sofja kernel: PCI: Enabling device 0000:00:1d.0 (0000 -> 0001)
Mar 21 05:13:10 sofja kernel: ACPI: PCI Interrupt 0000:00:1d.0[A] -> GSI 16 (lev
el, low) -> IRQ 16
Mar 21 05:13:10 sofja kernel: usb usb2: root hub lost power or was reset
Mar 21 05:13:10 sofja kernel: PCI: Enabling device 0000:00:1d.1 (0000 -> 0001)
Mar 21 05:13:10 sofja kernel: ACPI: PCI Interrupt 0000:00:1d.1[B] -> GSI 17 (lev
el, low) -> IRQ 21
Mar 21 05:13:10 sofja kernel: usb usb3: root hub lost power or was reset
Mar 21 05:13:10 sofja kernel: PCI: Enabling device 0000:00:1d.2 (0000 -> 0001)
Mar 21 05:13:10 sofja kernel: ACPI: PCI Interrupt 0000:00:1d.2[C] -> GSI 18 (lev
el, low) -> IRQ 22
Mar 21 05:13:10 sofja kernel: usb usb4: root hub lost power or was reset
Mar 21 05:13:10 sofja kernel: PCI: Enabling device 0000:00:1d.3 (0000 -> 0001)
Mar 21 05:13:10 sofja kernel: ACPI: PCI Interrupt 0000:00:1d.3[D] -> GSI 19 (lev
el, low) -> IRQ 20
Mar 21 05:13:10 sofja kernel: usb usb5: root hub lost power or was reset
Mar 21 05:13:10 sofja kernel: PCI: Enabling device 0000:00:1d.7 (0000 -> 0002)
Mar 21 05:13:10 sofja kernel: ACPI: PCI Interrupt 0000:00:1d.7[D] -> GSI 19
(level, low) -> IRQ 20
Mar 21 05:13:10 sofja kernel: ACPI: PCI Interrupt 0000:00:1e.2[A] -> GSI 22
(level, low) -> IRQ 18
Mar 21 05:13:10 sofja kernel: ACPI: PCI Interrupt 0000:00:1e.3[B] -> GSI 23
(level, low) -> IRQ 19
Mar 21 05:13:10 sofja kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16
(level, low) -> IRQ 16
Mar 21 05:13:10 sofja kernel: ACPI: PCI Interrupt 0000:0b:02.0[A] -> GSI 21
(level, low) -> IRQ 23
Mar 21 05:13:10 sofja kernel: pnp: Device 00:09 activated.
Mar 21 05:13:10 sofja kernel: pnp: Device 00:0a activated.
Mar 21 05:13:10 sofja kernel: ata1.00: configured for UDMA/100
Mar 21 05:13:10 sofja kernel: sd 0:0:0:0: [sda] 156301488 512-byte hardware
sectors (80026 MB)
Mar 21 05:13:10 sofja kernel: sd 0:0:0:0: [sda] Write Protect is off
Mar 21 05:13:10 sofja kernel: sd 0:0:0:0: [sda] Write cache: enabled, read
cache: enabled, doesn't support DPO or FUA
Mar 21 05:13:10 sofja kernel: ata2.00: configured for UDMA/33
Mar 21 05:13:10 sofja kernel: thinkpad_acpi: fan watchdog: enabling fan
Mar 21 05:13:10 sofja kernel: sd 0:0:0:0: [sda] Starting disk
Mar 21 05:13:10 sofja acpid: received event "processor CPU 00000081 00000000"
Mar 21 05:13:10 sofja acpid: notifying client 2337[0:0]
Mar 21 05:13:10 sofja acpid: client has disconnected
Mar 21 05:13:10 sofja acpid: notifying client 2120[68:68]
Mar 21 05:13:10 sofja acpid: completed event "processor CPU 00000081 00000000"
Mar 21 05:13:10 sofja kernel: Restarting tasks ... done.
Mar 21 05:13:10 sofja kernel: usb 4-2: USB disconnect, address 3
Mar 21 05:13:10 sofja NetworkManager: <info>  Waking up from sleep.
Mar 21 05:13:10 sofja NetworkManager: <info>  eth0: Device is fully-supported
using driver 'tg3'.
Mar 21 05:13:10 sofja NetworkManager: <info>  (eth0): exporting device as
/org/freedesktop/NetworkManager/Device/2
Mar 21 05:13:10 sofja NetworkManager: <info>  Now managing wired Ethernet
(802.3) device 'eth0'.
Mar 21 05:13:10 sofja NetworkManager: <info>  Bringing up device eth0
Mar 21 05:13:11 sofja kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
Mar 21 05:13:11 sofja acpid: client connected from 2337[0:0]
Mar 21 05:13:11 sofja acpid: 1 client rule loaded
Mar 21 05:13:11 sofja NetworkManager: <info>  Deactivating device eth0.
Mar 21 05:13:11 sofja NetworkManager: <info>  ath0: Device is fully-supported
using driver 'ath5k_pci'.
Mar 21 05:13:11 sofja NetworkManager: <info>  (ath0): exporting device as
/org/freedesktop/NetworkManager/Device/5
Mar 21 05:13:11 sofja NetworkManager: <info>  Now managing wireless (802.11)
device 'ath0'.
Mar 21 05:13:11 sofja NetworkManager: <info>  Bringing up device ath0
Mar 21 05:13:11 sofja kernel: usb 4-2: new full speed USB device using uhci_hcd
and address 4
Mar 21 05:13:11 sofja kernel: ADDRCONF(NETDEV_UP): ath0: link is not ready
Mar 21 05:13:11 sofja NetworkManager: <info>  Deactivating device ath0.
Mar 21 05:13:11 sofja NetworkManager: <info>  (eth0) supplicant interface is now
in state 2 (from 1).
Mar 21 05:13:11 sofja NetworkManager: <info>  (ath0) supplicant interface is now
in state 2 (from 1).
Mar 21 05:13:11 sofja kernel: usb 4-2: configuration #1 chosen from 1 choice
Comment 1 Matthias Runge 2007-11-23 04:11:31 EST
Older kernel versions seem to be affected, too. Even a vanilla 2.6.22.5 does not
work. Looks like a problem in pm-suspend (and affected parts) or misconfigured.
Comment 2 Matthias Runge 2007-11-26 02:07:38 EST
adding 
SUSPEND_MODULES="ath5k" to /etc/pm/config.d/unload_modules
solves this bug.

Note You need to log in before you can comment on or make changes to this bug.