Bug 39607 - at boot , initscripts always check root partition
Summary: at boot , initscripts always check root partition
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL: univ.uoradea.ro
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-08 10:57 UTC by Marius Onica
Modified: 2014-03-17 02:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-22 20:45:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to /etc/rc.d/rc.sysinit to avoid running fsck on reiserfs partitions (389 bytes, patch)
2001-08-03 16:38 UTC, David Rees
no flags Details | Diff

Description Marius Onica 2001-05-08 10:57:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
if on root partition is a reiserfs filesystem at boot the operating
system always want to check the filesystem

How reproducible:
Always

Steps to Reproduce:
1.halt
2.boot
3.
	

Actual Results:  At this sequence from the rc.sysinit the system always
stops and
asks if I want to perform a fsck 
if [ -z "$fastboot" -a "$ROOTFSTYPE" != "nfs" ]; then
 
        STRING=$"Checking root filesystem"
        echo $STRING
	initlog -c "fsck -T -a $fsckoptions /"
        rc=$?


Additional info:

Comment 1 Bill Nottingham 2001-05-08 15:31:57 UTC
Doesn't the reiserfs fsck Do The Right Thing if it's unmounted cleanly?

Assigning to reiserfs-utils.

Comment 2 Bernhard Rosenkraenzer 2001-05-09 09:45:20 UTC
It doesn't do the right thing because reiserfs fsck is ultimately broken 
(which is one of the reasons we aren't supporting it on root filesystems).

-T isn't implemented at all (will fix), -a is supposed to enter a "do nothing 
mode" (and doesn't work).

Looking into it.


Comment 3 Nikita Danilov 2001-05-14 11:22:09 UTC
ReiserFS doesn't require fsck utility, because it provides meta-data journalling.
/sbin/reiserfsck is to repair fs corrupted due to internal kernel error of disk
IO error,
it's not a substitute for the traditional fsck and requires interaction with user
most of the time. Proper way to fix this is either modify rc scripts or symlink
/sbin/fsck.reiserfs to /bin/true.


Comment 4 fsolari 2001-08-01 23:10:34 UTC
Just as Nikita says, Reiser FS is not to be checked 'automatically' by the 
utility, so it's better to put 0 0 at the 5th and 6th fields in /etc/fstab
for any Reiser Filesystem you have.



Comment 5 David Rees 2001-08-03 16:34:56 UTC
Any chance this fix will be making it into initscripts?

As Nikita said, linking /sbin/fsck.reiserfs to /bin/true is one fix, other other is to fix /etc/rc.sysinit with the patch I will be attaching.

Comment 6 David Rees 2001-08-03 16:38:35 UTC
Created attachment 26092 [details]
Patch to /etc/rc.d/rc.sysinit to avoid running fsck on reiserfs partitions

Comment 7 Bernhard Rosenkraenzer 2001-08-03 16:41:12 UTC
Assigning back to initscripts - I don't think fixing reiserfsck would be such a good 
idea (would break compatibility with everyone else, and doing it right would mean 
rewriting reiserfs ;) )


Comment 8 Bill Nottingham 2001-08-03 18:42:56 UTC
I object to the general idea of reiserfsck being handled differently than other
filesystems. If it's not meant to be run generally, don't put the binary there
with that name.

Comment 9 Bill Nottingham 2005-02-22 20:45:50 UTC
Closing out bugs on older, no longer supported releases. Apologies for any lack
of response.


Note You need to log in before you can comment on or make changes to this bug.