Bug 396341 - RFE: yum-skip-broken support
RFE: yum-skip-broken support
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 01:37 EST by Gilboa Davara
Modified: 2008-03-13 03:47 EDT (History)
0 users

See Also:
Fixed In Version: 2.0.4-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 03:38:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilboa Davara 2007-11-23 01:37:45 EST
Description of problem:
yum-skip-broken is not supported by yumex; if a certain package is broken all
the transaction will fail.
Comment 1 Tim Lauridsen 2007-11-23 01:47:26 EST
Try start yumex with 'yumex --skip-broken'.
I will be added to GUI in a future version.

Comment 2 Gilboa Davara 2007-11-23 02:45:18 EST
My Fedora 8 machine is DOA (flood); but at least on my CentOS5 machine, yumex
--skip-broken returns:

yumex.pyc: error: no such option: --skip-broken
Quit by User
Comment 3 Tim Lauridsen 2007-11-23 05:55:06 EST
Look like some problems has been introduced since i have added the feature. :(
Comment 4 Gilboa Davara 2007-11-24 11:33:28 EST
Just to be certain I'll test it again on my F8 workstation @work.

Thanks for the prompt answer.
Comment 5 Tim Lauridsen 2007-11-25 03:15:40 EST
Ok, i tracked down the error, it is fixed upstream, it will be available in
yumex 2.0.4.

It you what to test it then check this:
http://www.yum-extender.org/wiki/Yumex/Development#head-902665d30c83d709132948e3efae142c79c32b44
Comment 6 Gilboa Davara 2007-11-25 08:10:25 EST
git-current seems OK to me.
I'll test it again on my CentOS machine later today.

- Gilboa
Comment 7 Fedora Update System 2008-02-21 09:00:40 EST
yumex-2.0.4-1.fc8 has been submitted as an update for Fedora 8
Comment 8 Fedora Update System 2008-02-21 09:04:44 EST
yumex-2.0.4-1.fc7 has been submitted as an update for Fedora 7
Comment 9 Fedora Update System 2008-02-25 19:24:01 EST
yumex-2.0.4-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yumex'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-1940
Comment 10 Fedora Update System 2008-03-13 03:38:32 EDT
yumex-2.0.4-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-03-13 03:47:55 EDT
yumex-2.0.4-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.