Bug 396441 - PyKDE compilation doesn't work...
PyKDE compilation doesn't work...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PyKDE (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 04:43 EST by Oliver Falk
Modified: 2007-12-06 15:52 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.16.0-11.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 15:52:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-11-23 04:43:16 EST
Short log (3.6.0-7) on x86:
g++ -c -Wno-deprecated-declarations -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables -fPIC -Wall -W -D_REENTRANT
-DQT_NO_DEBUG -DQT_THREAD_SUPPORT -I. -I../extra/kde353 -I/usr/include/kde
-I/usr/include/python2.5 -I/usr/lib/qt-3.3/mkspecs/default
-I/usr/lib/qt-3.3/include -o sipkdecorepart0.o sipkdecorepart0.cpp
In file included from sipkdecorepart0.cpp:24:
sip/kdecore/bytearray.sip:26:31: error: sipdcopQValueList.h: No such file or
directory
sipkdecorepart0.cpp:26:27: error: sipqtQVariant.h: No such file or directory
sip/kdecore/kconfigbase.sip:299:61: error: sipkdecoreKConfigBase.h: No such file
or directory
sip/kdecore/kconfigdata.sip:95:33: error: sipkdecoreKEntryMap.h: No such file or
directory
sip/kdecore/kconfigdata.sip:96:30: error: sipkdecoreKEntry.h: No such file or
directory
sip/kdecore/kconfigdata.sip:97:33: error: sipkdecoreKEntryKey.h: No such file or
directory
sip/kdecore/bytearray.sip:582:28: error: sipdcopDCOPRef.h: No such file or directory
sip/kdecore/bytearray.sip:583:27: error: sipqtQCString.h: No such file or directory
sip/kdecore/bytearray.sip:667:26: error: sipqtQString.h: No such file or directory
sip/kdecore/kmacroexpander.sip:123:24: error: sipqtQChar.h: No such file or
directory
sip/kdecore/kmacroexpander.sip:205:30: error: sipqtQStringList.h: No such file
or directory
sip/kdecore/ktimezones.sip:191:33: error: sipkdecoreKTimezone.h: No such file or
directory
sip/kdecore/ktimezones.sip:143:39: error: sipkdecoreKTimezoneSource.h: No such
file or directory
sip/kdecore/kmountpoint.sip:120:35: error: sipkdecoreKMountPoint.h: No such file
or directory
sip/kdecore/kmountpoint.sip:121:38: error: sipkdecoreKMountPointPtr.h: No such
file or directory
sip/kdecore/klockfile.sip:75:44: error: ../kdecore/sipkdecoreKLockFile.h: No
such file or directory
sip/kdecore/kconfigskeleton.sip:125:32: error: sipkdecorelonglong.h: No such
file or directory
sip/kdecore/kconfigskeleton.sip:126:33: error: sipkdecoreulonglong.h: No such
file or directory
sip/kdecore/kconfigskeleton.sip:1086:53: error:
sipkdecoreKConfigSkeletonItemEnumChoice.h: No such file or directory
sip/kdecore/kconfig.sip:196:37: error: sipkdecoreKSharedConfig.h: No such file
or directory
sip/kdecore/kcompletion.sip:155:33: error: sipkdecoreKShortcut.h: No such file
or directory
sipkdecorepart0.cpp: In function 'PyObject* func_locateLocal(PyObject*, PyObject*)':
sipkdecorepart0.cpp:3794: error: 'locateLocal' was not declared in this scope
sipkdecorepart0.cpp: In function 'PyObject* func_locate(PyObject*, PyObject*)':
sipkdecorepart0.cpp:3824: error: 'locate' was not declared in this scope
sipkdecorepart0.cpp: In function 'PyObject* func_i18n(PyObject*, PyObject*)':
sipkdecorepart0.cpp:3851: error: 'i18n' was not declared in this scope
sipkdecorepart0.cpp:3865: error: 'i18n' was not declared in this scope
sipkdecorepart0.cpp:3880: error: 'i18n' was not declared in this scope
sipkdecorepart0.cpp: In function 'PyObject* func_IconSize(PyObject*, PyObject*)':
sipkdecorepart0.cpp:3906: error: 'IconSize' was not declared in this scope
sipkdecorepart0.cpp: In function 'PyObject* func_UserIconSet(PyObject*, PyObject*)':
sipkdecorepart0.cpp:3933: error: 'UserIconSet' was not declared in this scope
sipkdecorepart0.cpp: In function 'PyObject* func_UserIcon(PyObject*, PyObject*)':
sipkdecorepart0.cpp:3963: error: 'UserIcon' was not declared in this scope
sipkdecorepart0.cpp:3980: error: 'UserIcon' was not declared in this scope
sipkdecorepart0.cpp: In function 'PyObject* func_MainBarIconSet(PyObject*,
PyObject*)':
sipkdecorepart0.cpp:4010: error: 'MainBarIconSet' was not declared in this scope
sipkdecorepart0.cpp: In function 'PyObject* func_MainBarIcon(PyObject*, PyObject*)':
sipkdecorepart0.cpp:4041: error: 'MainBarIcon' was not declared in this scope
sipkdecorepart0.cpp:4058: error: 'MainBarIcon' was not declared in this scope
sipkdecorepart0.cpp: In function 'PyObject* func_SmallIconSet(PyObject*,
PyObject*)':
sipkdecorepart0.cpp:4088: error: 'SmallIconSet' was not declared in this scope
sipkdecorepart0.cpp: In function 'PyObject* func_SmallIcon(PyObject*, PyObject*)':
sipkdecorepart0.cpp:4119: error: 'SmallIcon' was not declared in this scope
sipkdecorepart0.cpp:4136: error: 'SmallIcon' was not declared in this scope
sipkdecorepart0.cpp: In function 'PyObject* func_BarIconSet(PyObject*, PyObject*)':
sipkdecorepart0.cpp:4166: error: 'BarIconSet' was not declared in this scope
sipkdecorepart0.cpp: In function 'PyObject* func_BarIcon(PyObject*, PyObject*)':
sipkdecorepart0.cpp:4197: error: 'BarIcon' was not declared in this scope
sipkdecorepart0.cpp:4214: error: 'BarIcon' was not declared in this scope
sipkdecorepart0.cpp: In function 'PyObject* func_DesktopIconSet(PyObject*,
PyObject*)':
sipkdecorepart0.cpp:4244: error: 'DesktopIconSet' was not declared in this scope
sipkdecorepart0.cpp: In function 'PyObject* func_DesktopIcon(PyObject*, PyObject*)':
sipkdecorepart0.cpp:4275: error: 'DesktopIcon' was not declared in this scope
sipkdecorepart0.cpp:4292: error: 'DesktopIcon' was not declared in this scope
sip/kdecore/kmountpoint.sip: In function 'PyObject*
convertFrom_KMountPoint_List(void*, PyObject*)':
sip/kdecore/kmountpoint.sip:142: warning: taking address of temporary
sipkdecorepart0.cpp: In function 'void release_Display(void*, int)':
sipkdecorepart0.cpp:35619: warning: possible problem detected in invocation of
delete operator:
sipkdecorepart0.cpp:35619: warning: invalid use of undefined type 'struct _XDisplay'
/usr/lib/qt-3.3/include/qwindowdefs.h:141: warning: forward declaration of
'struct _XDisplay'
sipkdecorepart0.cpp:35619: note: neither the destructor nor the class-specific
operator delete will be called, even if they are declared when the class is defined.
sipkdecorepart0.cpp: At global scope:
sipkdecorepart0.cpp:35625: warning: unused parameter 'sipPy'
sipkdecorepart0.cpp:35625: warning: unused parameter 'sipIsErr'
sipkdecorepart0.cpp: In function 'PyObject* convertFrom_Display(void*, PyObject*)':
sipkdecorepart0.cpp:35666: warning: unused variable 'sipCpp'
sip/kdecore/kconfigbase.sip: In function 'PyObject* convertFrom_ulonglong(void*,
PyObject*)':
sip/kdecore/kconfigbase.sip:309: warning: unused variable 'LongLong'
sip/kdecore/kwinmodule.sip: In function 'int
convertTo_QValueList_2100(PyObject*, void**, int*, PyObject*)':
sip/kdecore/kwinmodule.sip:142: warning: dereferencing type-punned pointer will
break strict-aliasing rules
sip/kdecore/kwinmodule.sip: In function 'PyObject*
convertFrom_QValueList_2100(void*, PyObject*)':
sip/kdecore/kwinmodule.sip:111: warning: unused variable 'inst'
make[2]: *** [sipkdecorepart0.o] Error 1
make[2]: Leaving directory
`/var/hosting/INTERNAL/LKERNAT/home/oliver/cvs/Fedora/extras.public/PyKDE/PyKDE-3.16.0/kdecore'
make[1]: *** [all] Error 2
make[1]: Leaving directory
`/var/hosting/INTERNAL/LKERNAT/home/oliver/cvs/Fedora/extras.public/PyKDE/PyKDE-3.16.0'
error: Bad exit status from /var/tmp/rpm-tmp.46696 (%build)




However. I first tried to compile PyKDE on alpha, since that spotted errors
about missing header files, I tried it on i386 to check if the same happens.
Alpha is more or less F-8 and i386 is Rawhide.

However, can you try to build it and let me know if you also encounter problems.
And if, can you try to fix it please.

Thx!
Comment 1 Rex Dieter 2007-11-23 22:25:18 EST
* Fri Nov 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.16.0-8
- sip-4.7 patch (#396441)
Comment 2 Fedora Update System 2007-11-26 13:39:27 EST
PyKDE-3.16.0-11.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PyKDE'
Comment 3 Fedora Update System 2007-11-26 13:52:37 EST
PyKDE-3.16.0-11.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PyKDE'
Comment 4 Fedora Update System 2007-12-06 15:52:17 EST
PyKDE-3.16.0-11.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2007-12-06 15:52:32 EST
PyKDE-3.16.0-11.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.