Bug 39663 - Rebuild of Ash-0.2-26 doesnt work.
Summary: Rebuild of Ash-0.2-26 doesnt work.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ash   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-08 15:07 UTC by Need Real Name
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 23:06:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-05-08 15:07:27 UTC
Description of Problem:
Downloaded the src rpm for ash-0.2-26 to rebuild it against a different
libc and it DID compile and run, but the shell scripts i use dont run under
it. So I rebuild it against my 7.0 (up to date as of 5/7) and I get the
same thing.

How Reproducible:


Steps to Reproduce:
1. rpm --recompile ash-0.2-26.src.rpm
2. 
3. 

Actual Results:


Expected Results: 
An ash shell that works just like the one in the binary package w/ the 7.0
release.


Additional Information:

Comment 1 Crutcher Dunnavant 2001-06-25 23:46:18 UTC
I really cant work with this much info.
In what way do they fail? What is it doing, that it was not?

Comment 2 Trond Eivind Glomsrxd 2001-12-06 23:06:46 UTC
Closing, it builds on the current release which is what is supports.

Comment 3 Need Real Name 2001-12-07 12:24:47 UTC
The Issue is that following the property recoompile steps does NOT produce the 
equivelant binary package that is being distributed. Yes it compiles and builds 
and all that....but if i install it, i get a DIFFERENT ash that does not 
function the same as the version that you (RH) built and distributed, even 
though the package ash-0.2-26.src.rpm should produce the EXACT equivalent of 
ash-0.2-26-i386.rpm.

Comment 4 Trond Eivind Glomsrxd 2001-12-07 14:21:56 UTC
It should produce an equivalent binary on an identical system - yours isn't.

Comment 5 Need Real Name 2001-12-07 17:07:35 UTC
I built it on a RedHat 7.0 system Fully updated (as of that time). The binary 
produced DID NOT FUNCTION THE SAME. ITs been a long time now so i dont recall 
the exact differences, but basically there werer a binch of my shell scripts 
AND REDHAT scripts that DID NOT RUN UNDER THAT COMPILED VERSION. Ash would 
report back syntax errors. But using the pre-compiled RH version they worked.
That is a bug.


Note You need to log in before you can comment on or make changes to this bug.