Bug 396691 - Samba 3.0.27-0.fc7 fails to mount partition with connection lost error message
Samba 3.0.27-0.fc7 fails to mount partition with connection lost error message
Status: CLOSED DUPLICATE of bug 394531
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 07:18 EST by Max E
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-23 12:18:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages after samba update (9.35 KB, text/plain)
2007-11-23 07:18 EST, Max E
no flags Details

  None (edit)
Description Max E 2007-11-23 07:18:36 EST
Description of problem:
When mounting drive partition from RISCOS (under LanMan98), Samba fails to mount
drive mounting.  RISCOS error message gives: Error when reading
LanMan98::user.$-Connection Lost.  

SMB daemon on Linux server then gives (from /var/log/messages): 

Nov 23 10:42:46 localhost smbd[3328]: [2007/11/23 10:42:46, 0]
lib/util.c:smb_panic(1654) 
Nov 23 10:42:46 localhost smbd[3328]:   PANIC (pid 3328): push_ascii - dest_len
== -1 
Nov 23 10:42:46 localhost smbd[3328]: [2007/11/23 10:42:46, 0]
lib/util.c:log_stack_trace(1758) 
Nov 23 10:42:46 localhost smbd[3328]:   BACKTRACE: 14 stack frames: 
Nov 23 10:42:46 localhost smbd[3328]:    #0 smbd(log_stack_trace+0x2d) [0x80244bbd] 
Nov 23 10:42:46 localhost smbd[3328]:    #1 smbd(smb_panic+0x5d) [0x80244ced] 
Nov 23 10:42:46 localhost smbd[3328]:    #2 smbd(push_ascii+0xf7) [0x8022d487] 
Nov 23 10:42:46 localhost smbd[3328]:    #3 smbd(push_string_fn+0x4c) [0x8022d4dc] 
Nov 23 10:42:46 localhost smbd[3328]:    #4 smbd(srvstr_push_fn+0x54) [0x800b6424] 
Nov 23 10:42:46 localhost smbd[3328]:    #5 smbd [0x8009bff1] 
Nov 23 10:42:46 localhost smbd[3328]:    #6 smbd [0x8009ecf5] 
Nov 23 10:42:46 localhost smbd[3328]:    #7 smbd(handle_trans2+0x237) [0x800a2a07] 
Nov 23 10:42:46 localhost smbd[3328]:    #8 smbd(reply_trans2+0x6bb) [0x800a91bb] 
Nov 23 10:42:46 localhost smbd[3328]:    #9 smbd [0x800c5ed0] 
Nov 23 10:42:46 localhost smbd[3328]:    #10 smbd(smbd_process+0x836) [0x800c6f66] 
Nov 23 10:42:46 localhost smbd[3328]:    #11 smbd(main+0xbdd) [0x80321e1d] 
Nov 23 10:42:46 localhost smbd[3328]:    #12
/lib/i686/nosegneg/libc.so.6(__libc_start_main+0xe0) [0x68bf70] 
Nov 23 10:42:46 localhost smbd[3328]:    #13 smbd [0x8004a231] 
Nov 23 10:42:46 localhost smbd[3328]: [2007/11/23 10:42:46, 0]
lib/fault.c:dump_core(181) 
Nov 23 10:42:46 localhost smbd[3328]:   dumping core in /var/log/samba/cores/smbd 
Nov 23 10:42:46 localhost smbd[3328]: 


Version-Release number of selected component (if applicable):

From smbstatus: Samba version 3.0.27-0.fc7

How reproducible:

Try and mount any SMB share from RISCOS machine

Steps to Reproduce:
1. On RISCOS desktop machine, click on Net - a list of machines appears (so this
means that the smbd is actually sending out a list of shares)
2. Try opening any of the presented shares
3. Error message: RISCOS error message gives: Error when reading
LanMan98::user.$-Connection Lost.  appears
  
Actual results:
Non availability of SMB mounts

Expected results:

Availability of Samba shares

Additional info:

Some quite interesting stuff taken from when the latest version of samba was
upgraded to - from /var/log/messages (see attached file).
Comment 1 Max E 2007-11-23 07:18:36 EST
Created attachment 267531 [details]
/var/log/messages after samba update
Comment 2 Max E 2007-11-23 07:27:19 EST
Interestingly enough, this bug doesn't seem to effect printing.  This still
happily works.  The only thing that is effected is opening of files/directories.
Comment 3 Max E 2007-11-23 08:46:04 EST
Sorry, forgot to add that this problem did not exist on 3.0.26, and that nothing
has been upgraded on RISCOS side.
Comment 4 Max E 2007-11-23 10:07:39 EST
Retrograded to version 3.0.26a for the moment, which has fixed the problem. 
Version 3.0.27 is definitely broken.  Keeping high priority, as this probably a
more underlying issue at fault here.
Comment 5 Simo Sorce 2007-11-23 12:18:23 EST

*** This bug has been marked as a duplicate of 394531 ***

Note You need to log in before you can comment on or make changes to this bug.