Bug 396851 - Anaconda: "TypeError: rpmdb open failed"
Anaconda: "TypeError: rpmdb open failed"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 10:05 EST by Lubomir Kundrak
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 13:33:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-11-23 10:05:14 EST
Description of problem:

               | anaconda 11.4.0.1 exception report          ^ |                
               | Traceback (most recent call first):         # |                
               |   File                                      : |                
               | "/usr/lib/python2.5/site-packages/yum/rpms  : |                
               | ack.py", line 214, in _all_packages         : |                
               |     mi = ts.dbMatch()                       : |                
               |   File                                      : |                
               | "/usr/lib/python2.5/site-packages/yum/rpms  : |                
               | ack.py", line 243, in _make_header_dict     : |                
               |     for (hdr, idx) in                       : |                
               | self._all_packages():                       : |                
               |   File                                      v |                
               | "/usr/lib/python2.5/site-packages/yum/rpms  ^ |                
               | ack.py", line 59, in _get_pkglist           : |                
               |     self._make_header_dict()                : |
               |   File                                      # |
               | "/usr/lib/python2.5/site-packages/yum/rpms  : |                
               | ack.py", line 158, in simplePkgList         : |                
               |     return self.pkglist                     : |
               |   File                                      : |                
               | "/usr/lib/python2.5/site-packages/yum/__in  : |                
               | it__.py", line 517, in _getGroups           : |                
               |     pkglist = self.rpmdb.simplePkgList()    : |
               |   File                                      v |                
               | "/usr/lib/python2.5/site-packages/yum/__in  ^ |                
               | it__.py", line 542, in <lambda>             : |                
               |     comps = property(fget=lambda self:      : |
               | self._getGroups(),                          : |
               |   File "/usr/lib/anaconda/yuminstall.py",   : |                
               | line 598, in doGroupSetup                   : |                
               |     sel = filter(lambda g: g.selected,      # |
               | self.ayum.comps.get_groups())               : |                
               |   File "/usr/lib/anaconda/yuminstall.py",   : |                
               | line 702, in doRepoSetup                    : |                
               |     self.doGroupSetup()                     : |
               |   File "/usr/lib/anaconda/backend.py",      v |                
               | line 183, in doRepoSetup                    ^ |                
               |     if                                      : |                
               | anaconda.backend.doRepoSetup(anaconda) ==   : |
               | DISPATCH_BACK:                              : |
               |   File "/usr/lib/anaconda/dispatch.py",     : |                
               | line 204, in moveStep                       : |                
               |     rc = stepFunc(self.anaconda)            : |
               |   File "/usr/lib/anaconda/dispatch.py",     : |                
               | line 127, in gotoNext                       # |                
               |     self.moveStep()                         : |                
               |   File "/usr/lib/anaconda/text.py", line    : |
               | 657, in run                                 v |                
               |   File "/usr/lib/anaconda/dispatch.py",     ^ |                
               | line 127, in gotoNext                       : |
               |     self.moveStep()                         : |
               |   File "/usr/lib/anaconda/text.py", line    : |
               | 657, in run                                 : |
               |     anaconda.dispatch.gotoNext()            : |
               |   File "/usr/bin/anaconda", line 941, in    : |
               | <module>                                    : |
               |     anaconda.intf.run(anaconda)             : |
               | TypeError: rpmdb open failed                : |
               |                                             # |
               |                                             v |                

               |no dbpath has been set                         |                
               |    +----+s databa+------+nt/sysi+-------+bpath|                
               |    | OK |        | Save |       | Debug |     |                
               |    +----+        +------+       +-------+     |                


Version-Release number of selected component (if applicable):

11.4.0.1, with the isys fix

Steps to Reproduce:
1. I created empty 5G file with qemu-img and chose default partitioning
2. Seems only reproducible with the kickstart file below

Additional info:

My kickstart file was:

text
install
url --url http://172.31.2.1/linux/fedora/rawhide/i386/os/
network --bootproto=dhcp
timezone Europe/Prague
firstboot --enable

The output is so ugly, because I was unable to save an exception log, as the
following happened when I hit 'Save:'

              Traceback (most recent call last):                                
  File "/usr/bin/anaconda", line 945, in <module>elects   |  <F12> next screen
    handleException(anaconda, sys.exc_info())
  File "/usr/lib/anaconda/exception.py", line 445, in handleException
    runSaveDialog(anaconda, "/tmp/anacdump.txt")
  File "/usr/lib/anaconda/exception.py", line 329, in runSaveDialog
    saveWin.run()
  File "/usr/lib/anaconda/text.py", line 229, in run
    result = toplevel.run()
  File "/usr/lib/python2.5/site-packages/snack.py", line 666, in run
    self.create(x, y)
  File "/usr/lib/python2.5/site-packages/snack.py", line 662, in create
    self.screen.gridWrappedWindow(self, self.title, x, y)
AttributeError: 'NoneType' object has no attribute 'gridWrappedWindow'
install exited abnormally [1/1]
Comment 1 Chris Lumens 2007-11-28 13:33:31 EST
This should be fixed in the next build of anaconda.  Please file the bug about
the exception dialog in text mode separately.  Thanks.
Comment 2 Lubomir Kundrak 2007-11-28 14:39:16 EST
Chris: I can't see anything after quick look at the git log that would look as a
fix for this. Can I fix this by adding something to my updates.img? When will be
the next release? Thanks.
Comment 3 Chris Lumens 2007-11-28 16:36:42 EST
You want to use git show 2aac38821cf72d2bbb42a7cb85a89c871c706422, which will
show you that there are a handful of libraries in the nss package that we need
to be including in our installation images.  You can toss those libraries in an
updates image which will let anaconda get farther, but you'll just get a crash
at the end of installation due to another problem.

I hope to rebuild today.

Note You need to log in before you can comment on or make changes to this bug.