Bug 396871 - fixfiles -C file restore examines all filesystems
fixfiles -C file restore examines all filesystems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 10:12 EST by Michael Young
Modified: 2008-05-07 16:17 EDT (History)
0 users

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 16:17:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
suggested patch (701 bytes, patch)
2007-11-23 10:12 EST, Michael Young
no flags Details | Diff

  None (edit)
Description Michael Young 2007-11-23 10:12:15 EST
I noticed that updating selinux-policy-targeted was taking a very long time, and
noticed that a find command invoked by fixfiles was traversing our larger nfs
directories.
The problem seems to be that
sh -c "find $pattern" extra args
actually runs
find $pattern
and ignores the rest of the line. I suggest you move the closing quote to
include the remaining arguments, as in the attached patch.
I am seeing the bug with policycoreutils-2.0.31-15.fc8
Comment 1 Michael Young 2007-11-23 10:12:15 EST
Created attachment 267561 [details]
suggested patch
Comment 2 Daniel Walsh 2007-12-17 17:50:11 EST
Joseph can you investigate this one?
Comment 3 Daniel Walsh 2008-05-07 16:17:15 EDT
fixed in policycoreutils-2.0.34-7.fc8

Note You need to log in before you can comment on or make changes to this bug.