Bug 397201 - Anaconda of RHEL5> will crash if Cobbler is running on different httpd port then 80
Anaconda of RHEL5> will crash if Cobbler is running on different httpd port t...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael DeHaan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 14:34 EST by martin.minka
Modified: 2008-01-10 12:32 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 12:32:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen shot of Anaconda error message (16.13 KB, image/png)
2007-11-23 14:34 EST, martin.minka
no flags Details

  None (edit)
Description martin.minka 2007-11-23 14:34:40 EST
Description of problem:
I configured Cobbler to run on port 81 and tested it with CENTOS4. It worked fine.
Now I wanted to provision CENTOS5 and Anaconda exited abnormally. It is related
to the port setting.

Version-Release number of selected component (if applicable):
Tested with 0.602.

How reproducible:


Steps to Reproduce:
1. Configure httpd to listen on port 81.
2. Set in file settings: server: 'x.x.x.x:81'
3. Use CENTOS5 or RHEL5 distribution to boot.
  
Actual results:
Anaconda installer will stop with error message (see attachment):


Expected results:
It should work of course.

Additional info:
The problem is in the generate pxeconfig.cfg file. It contains kernel option
"syslog=81.0.212.194:25150".
Comment 1 martin.minka 2007-11-23 14:34:40 EST
Created attachment 267781 [details]
screen shot of Anaconda error message
Comment 2 martin.minka 2007-11-25 03:57:29 EST
work around is to start "cobbler sync" as part of this script:

#!/bin/bash
# change this line to your port number
cobbler sync

for file in `find /tftpboot/pxelinux.cfg -type f`
do sed "s/81:25150/25150/g" $file > $file.sed && mv $file.sed $file
done
Comment 3 Michael DeHaan 2007-11-26 11:21:48 EST
Thanks for the heads up on this.

The server field is for a server hostname or address, it does not accept a port,
as the field is used for multiple ports.  So this is technically an RFE to
support http servers running on non-default ports.

I've opened an item in Trac here to track the request:

https://hosted.fedoraproject.org/projects/cobbler/ticket/49#preview

I'll leave the bugzilla open also, though comments will be made on the Trac item.

Note You need to log in before you can comment on or make changes to this bug.