Bug 397261 - f-spot fails to start
f-spot fails to start
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 16:19 EST by Valent Turkovic
Modified: 2007-12-16 07:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-04 04:08:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 500129 None None None Never

  None (edit)
Description Valent Turkovic 2007-11-23 16:19:17 EST
Description of problem:
f-spot fails to start

Version-Release number of selected component (if applicable):
f-spot 0.4.0.0

How reproducible:
every time

Steps to Reproduce:
1. launch f-spot
2.
3.
  
Actual results:
$ f-spot
Initializing Mono.Addins
Starting new FSpot server
XXXXX
Mono.Data.SqliteClient.SqliteSyntaxException: no such table: tags
  at Mono.Data.SqliteClient.SqliteCommand.GetNextStatement (IntPtr pzStart,
System.IntPtr& pzTail, System.IntPtr& pStmt) [0x00000] 
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteReader (CommandBehavior
behavior, Boolean want_results, System.Int32& rows_affected) [0x00000] 
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteReader (CommandBehavior
behavior) [0x00000] 
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteReader () [0x00000] 
  at (wrapper remoting-invoke-with-check)
Mono.Data.SqliteClient.SqliteCommand:ExecuteReader ()
  at Banshee.Database.QueuedSqliteCommand.Execute () [0x00000] 
XXXXX
Can't get a connection to the dbus. Trying again...
Starting new FSpot server
Can't get a connection to the dbus. Trying again...
Starting new FSpot server
Can't get a connection to the dbus. Trying again...
Starting new FSpot server
Can't get a connection to the dbus. Trying again...
Starting new FSpot server
Can't get a connection to the dbus. Trying again...
Starting new FSpot server
Can't get a connection to the dbus. Trying again...
Starting new FSpot server
Can't get a connection to the dbus. Trying again...
Starting new FSpot server


Expected results:
to get f-spot and do it's thing on my photos :)

Additional info:
Comment 1 Mike Lococo 2007-11-24 13:50:25 EST
I see this is assigned, but there is no comment by the assignee acknowledging
that the bug has been confirmed.  I confirm this exact behavior, tried deleting
~/.gnome2/f-spot/ with no change in behavior.  Happy to perform additional steps
if more information is needed to diagnose.
Comment 2 Scott J Henson 2007-11-24 14:15:53 EST
Its quite clear that f-spot can't get a connection to dbus.  I'm not familiar
with f-spot, but maybe you could post the output of the flowing two commands to
get things moving.

pgrep dbus | xargs ps -f
echo $DBUS_SESSION_BUS_ADDRESS

Thanks.
Comment 3 Mike Lococo 2007-11-24 14:23:31 EST
[user]$ pgrep dbus | xargs ps -f
UID        PID  PPID  C STIME TTY      STAT   TIME CMD
dbus      2249     1  0 Nov22 ?        Ssl    0:26 dbus-daemon --system
mike     31441     1  0 Nov22 ?        S      0:00 /usr/bin/dbus-launch\
--exit-with-session /etc/X11/xinit/Xclients
mike     31442     1  9 Nov22 ?        Ssl  219:05 /bin/dbus-daemon --fork\
--print-pid 4 --print-address 7 --session

[user]$ echo $DBUS_SESSION_BUS_ADDRESS
unix:abstract=/tmp/dbus-nSBks9X39m,guid=71e40f88c103974ebb19490047464acb
Comment 4 Scott J Henson 2007-11-24 14:44:55 EST
Diving into the source it seems that the dbus stuff is a red herring and an
artifact of how f-spot initializes itself.  What I find odd is that your getting
references to Banshee in the traceback.  I'm not sure how that could happen, do
you maybe have a f-spot addin that works with banshee?  
Comment 5 Valent Turkovic 2007-11-24 17:01:04 EST
here are mine:

$ pgrep dbus | xargs ps -f
UID        PID  PPID  C STIME TTY      STAT   TIME CMD
dbus      1824     1  0 08:50 ?        Ssl    0:06 dbus-daemon --system
valentt   2432     1  0 08:51 ?        S      0:00 /usr/bin/dbus-launch
--exit-with-session /etc/X11/xinit/Xclients
valentt   2433     1  0 08:51 ?        Ssl    0:00 /bin/dbus-daemon --fork
--print-pid 4 --print-address 8 --session


$ echo $DBUS_SESSION_BUS_ADDRESS
unix:abstract=/tmp/dbus-86vD2BtOro,guid=c1e7b43272cc12e77feb14004747c9e8


HTH
Comment 6 Valent Turkovic 2007-11-24 17:03:33 EST
ps. AFAIK I don't have an f-spot addin that works with banshee
Comment 7 Mike Lococo 2007-11-25 14:22:46 EST
Please ignore my comments above.  I know I saw the DBUS error, but am not
positive that the rest of the output was the same.  I'm also no longer able to
reproduce the bug to perform additional testing and can't pinpoint the system
change (if any) that corrected the problem.  If I do obtain more reliable
information I'll report back again.
Comment 8 Valent Turkovic 2007-11-26 05:19:12 EST
Can I help with some more feedback? I would really like to use f-spot because I
came from my trip to Egypt and I have tons of photos that I need to sort out :)
Thanks :)
Comment 9 Christopher Aillon 2007-11-27 07:21:36 EST
I'm unable to reproduce this on fresh installs of i386 or x86-64 Fedora 8, or on
the i386 LiveCD...  was this an upgrade?
Comment 10 Valent Turkovic 2007-11-27 15:56:32 EST
It was a fresh install on laptop, I used 32bit version of Fedora 8 Gnome Live CD.
Comment 11 Valent Turkovic 2007-11-27 15:58:46 EST
I tried 'yum remove f-spot' and 'yum install f-spot' and I still have this issue.
Comment 12 Christopher Aillon 2007-12-04 04:08:47 EST
I reported this upstream (thought I made a comment here right after I reported
it...)  http://bugzilla.gnome.org/show_bug.cgi?id=500129

Valent, can you see if the suggestions posted there help?
Comment 13 Valent Turkovic 2007-12-05 07:27:43 EST
Nope,
# dbus-launch f-spot

gives me the same error :(
Comment 14 Valent Turkovic 2007-12-05 07:33:52 EST
to be precise here is the error I get:

$ dbus-launch f-spot

Initializing Mono.Addins
Starting new FSpot server
XXXXX
Mono.Data.SqliteClient.SqliteSyntaxException: no such table: tags
  at Mono.Data.SqliteClient.SqliteCommand.GetNextStatement (IntPtr pzStart,
System.IntPtr& pzTail, System.IntPtr& pStmt) [0x00000] 
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteReader (CommandBehavior
behavior, Boolean want_results, System.Int32& rows_affected) [0x00000] 
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteReader (CommandBehavior
behavior) [0x00000] 
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteReader () [0x00000] 
  at (wrapper remoting-invoke-with-check)
Mono.Data.SqliteClient.SqliteCommand:ExecuteReader ()
  at Banshee.Database.QueuedSqliteCommand.Execute () [0x00000] 
XXXXX
Can't get a connection to the dbus. Trying again...
Starting new FSpot server
Can't get a connection to the dbus. Trying again...
Comment 15 Valent Turkovic 2007-12-06 10:11:32 EST
I installed Google Picasa today and started using it... you can see I'm desperate :(
Comment 16 Christopher Aillon 2007-12-11 07:27:45 EST
Valent, there's another suggestion in the upstream bug I posted.  It would be
great it you could continue tracking this there as I am.  (Yes I know it means
another bugzilla account, but they will be able to better resolve this).
Comment 17 Valent Turkovic 2007-12-16 07:58:10 EST
rm ~/.gnome2/f-spot/photos.db

this fixed my issue :)

Note You need to log in before you can comment on or make changes to this bug.