Bug 397301 - [pata_amd] Fedora 8 fails to recognize parallel IDE disk drives
[pata_amd] Fedora 8 fails to recognize parallel IDE disk drives
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 16:21 EST by Harold Pritchett
Modified: 2008-10-10 11:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 11:49:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of the dmesg command on a Fedora Core 6 system (31.22 KB, text/plain)
2008-01-05 18:35 EST, Harold Pritchett
no flags Details
Output of the dmesg command on a Fedora 8 system (15.09 KB, text/plain)
2008-01-05 18:36 EST, Harold Pritchett
no flags Details
Output of the dmesg command on a RHEL 5 system (16.00 KB, text/plain)
2008-01-13 15:04 EST, Harold Pritchett
no flags Details

  None (edit)
Description Harold Pritchett 2007-11-23 16:21:00 EST
Description of problem:

I have a new system on which I am trying to install Fedora 8.

Hardware looks like this:
ASUS P5N-E Mobo
4 GB DDR2 memory
Intel Core2 Quad Processor
Western Digital 120 Ghz drive on Primary/Master IDE port
DVD-RW drive on Secondary/Master IDE port
4 Western Digital 500 Gb drives on SATA ports 1-4

The goal: This is to be a file/web/database server. I want to install the O/S on
the 120 Gb drive. The four 500 Gb drives are to be configured as a RAID5 array
with a hot spare and used for data storage.

My problem:
When I boot the Fedora 8 install DVD, it only can see the four SATA drives. The
IDE drive does not appear at all. I tried un-plugging the four SATA drives and
then the installer could not see any drives at all. I tried installing Fedora 7
and got the same result. Fedora core 6 does see all of the drives and can be
installed.



Version-Release number of selected component (if applicable):


How reproducible:
Every time I boot the i386 Fedora 8 install dvd, it fails to see the parallel
IDE drive.  Just for the heck, I booted an openSUSE 10.2 dvd, and it was able to
see the drive, and can install just fine.

Steps to Reproduce:
1.  Insert Fedora 8 install DVD in drive
2.  Boot.
3.
  
Actual results:

Installer loads.  Devices available for installation are sd0, sd1, sd2, and sd3.
 No sign of the Fifth parallel IDE drive.


Expected results:

I expect to see all five drives.  Earlier versions of Fedora (Core 6) do, as
well as other linux distributions.  Even windows can be installed on the
parallel drive.


Additional info:  I have downloaded the X86_64 version since I understand the
intel core2 processor is 64 bit enabled.  I will try it, but I don't have a lot
of hope that it will work different from the i386 version.
Comment 1 Chuck Ebbert 2008-01-02 19:21:19 EST
Do you know how to capture the kernel messages from the installer and upload them?
Comment 2 Harold Pritchett 2008-01-02 23:15:13 EST
No...

I don't suppose it's a matter of connecting a serial console and logging all of
the messages.  I wouldn't know how to set up a serial console for the bootable
image on the install dvd.
Comment 3 Chuck Ebbert 2008-01-04 18:40:23 EST
You should be able to go to a text console (ctrl-alt-f1 thru ctrl-alt-f4) and
use the dmesg command to get the messages.
Comment 4 Harold Pritchett 2008-01-05 10:54:18 EST
The system currently has Fedora Core 6 installed on it.  If I boot it with the
Fedora 8 rescue disk, mount a file system, and then do a "dmesg > file" will
that be sufficient?  I can then boot back into Fedora 6 and attach the file with
the dmesg output here.
Comment 5 Harold Pritchett 2008-01-05 18:35:48 EST
Created attachment 290894 [details]
Output of the dmesg command on a Fedora Core 6 system
Comment 6 Harold Pritchett 2008-01-05 18:36:41 EST
Created attachment 290895 [details]
Output of the dmesg command on a Fedora 8 system
Comment 7 Chuck Ebbert 2008-01-08 13:51:35 EST
pata_amd 0000:00:0d.0: version 0.3.9
PCI: Setting latency timer of device 0000:00:0d.0 to 64
scsi6 : pata_amd
scsi7 : pata_amd
ata5: PATA max UDMA/133 cmd 0x00000000000101f0 ctl 0x00000000000103f6 bmdma
0x000000000001fd00 irq 14
ata6: PATA max UDMA/133 cmd 0x0000000000010170 ctl 0x0000000000010376 bmdma
0x000000000001fd08 irq 15
ata5: port is slow to respond, please be patient (Status 0xd0)
ata5: SRST failed (errno=-16)

It is having trouble resetting the port.
Comment 8 Chuck Ebbert 2008-01-08 15:45:22 EST
Alan, is this problem possibly fixed by the 2.6.24 patches that force PIO0
before reset?
Comment 9 Alan Cox 2008-01-08 15:58:44 EST
I don't think so - the PIO 0 setup matters for devices not BIOS configured but
the onboard devices are BIOS set up so that isn't the problem. 

0xD0 is a sensible status - it means 'device busy' so one possibility would be
to roll a test kernel with a longer SRST delay and see how it behaves. It may
also be drive specific so looking for other examples of that device in bugzilla
might give us clues but the other cases I've seen are both ATAPI.


Comment 10 Harold Pritchett 2008-01-11 21:42:41 EST
Is there any additional information I can provide?
Comment 11 Harold Pritchett 2008-01-13 15:04:20 EST
Created attachment 291512 [details]
Output of the dmesg command on a RHEL 5 system
Comment 12 Harold Pritchett 2008-01-24 19:58:01 EST
What is the current status of this bug?  It have been no updates for over two
weeks.  This system is running the last version of Fedora which will load on the
hardware.  This is Fedora Core 6, and was dropped from support the end of last
year.  It needs to be updated so that it can remain current and secure.  
Comment 13 Chuck Ebbert 2008-01-24 20:33:46 EST
Fedora 6 isn't finding the CD drive:

Probing IDE interface ide1...
Probing IDE interface ide1...
Comment 14 Chuck Ebbert 2008-01-24 20:35:05 EST
Maybe there is some issue with the cabling?
Comment 15 Harold Pritchett 2008-01-24 21:18:05 EST
Actually, I removed the IDE CD drive to make things simpler.  The only Parallel
ATA drive is the disk.  I'm booting from a USB DVD-ROM drive to do the installs.
Comment 16 Alan Cox 2008-01-25 09:39:53 EST
Current status is - unable to duplicate even with the same controllers and as
close a setup as I can get.
Comment 17 Harold Pritchett 2008-01-25 10:35:52 EST
I really don't understand...  This sytem takes an inordinate amount of time to
boot.  I just assumed it was because of the large amount of memory (4 gb) and
the quad processor cpu.  I'm talking several minutes to run the post test, and
then when it actually starts to boot, it sits on a blank screen for almost a
minute before I see the grub banner.

Perhaps it's a BIOS setting???  Do you want me to reset the BIOS to the default
settings and try again???
Comment 18 Christopher Brown 2008-02-13 19:31:18 EST
Harold,

Not sure if I can help here but have you tried using cable select on the drives
as opposed to master/slave. You could also test with a different cable if you
have one - 80 pin preferably.

I would also have a look at the BIOS settings certainly.
Comment 19 Harold Pritchett 2008-10-10 11:41:16 EDT
Please close this problem.

I finally gave up on this machine.  It's now running windows server 2007 and is quite happy.  I put the Fedora system on a dual processor box with the same amount of memory and it's also quite happy.

Sorry for taking so long to get back, but I was not aware that this problem record was still open.

Harold

Note You need to log in before you can comment on or make changes to this bug.