Bug 397471 - [RFE] [PATCH] database consistency check
[RFE] [PATCH] database consistency check
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 17:07 EST by Pierre Ossman
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-24 13:27:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
yum-check.patch (3.46 KB, patch)
2007-11-23 17:07 EST, Pierre Ossman
no flags Details | Diff

  None (edit)
Description Pierre Ossman 2007-11-23 17:07:25 EST
Unfortunately, yum and rpm are not without their share of bugs. Sometimes you
get broken dependencies, or failed upgrades with duplicate packages. Apt has a
nice command which allows you to find and identify such problems, but yum does not.

The included patch adds a "check" command which adds that missing functionality.
It does two things:

 - Checks that every dependency for every package is satisfied, and prints out
those which are not.

 - Check that there is only one of each package installed. It excludes those in
installonlypkgs.

This covers the most common problems found, and gives enough information to
solve them. Automatic repair would also be nice, but it is not included here.
Comment 1 Pierre Ossman 2007-11-23 17:07:25 EST
Created attachment 267821 [details]
yum-check.patch
Comment 2 James Antill 2007-11-24 13:27:57 EST
 You want to install yum-utils and run package-cleanup (--problems does #1, and
--dupes does #2).

Note You need to log in before you can comment on or make changes to this bug.