Bug 397501 - stage2 on rescue cdrom ignored when used for http install
stage2 on rescue cdrom ignored when used for http install
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 17:28 EST by Jerry Vonau
Modified: 2008-01-18 22:51 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 16:10:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to loader (2.29 KB, patch)
2007-12-16 18:48 EST, Jerry Vonau
no flags Details | Diff

  None (edit)
Description Jerry Vonau 2007-11-23 17:28:25 EST
Description of problem:
anaconda fetches the minstg2.img while there is a rescue cd in the cdrom drive,
then fails mounting minstg2, as stage2 is already mounted from the cdrom, when
you select text install or have < 128 meg ram. 

Version-Release number of selected component (if applicable):
11.3.0.50 and 11.4.0.1

How reproducible:
always

Steps to Reproduce:
1.select text install on rescue cdrom
2.or have < 128 meg ram and select graphical install
3.
  
Actual results:
retrieves minstg2.img

Expected results:
uses stages2.img on rescue cdrom for text install
(saves the memory/bandwidth of minstg2)

Additional info:

in urlinstall.c
  /* require 128MB for use of graphical stage 2 due to size of image */
    if (FL_TEXT(flags) || totalMemory() < GUI_STAGE2_RAM) {
        stage2img = "minstg2.img";
        if (totalMemory() < GUI_STAGE2_RAM)
            logMessage(WARNING, "URLINSTALL falling back to non-GUI stage2 "
                       "due to insufficient RAM");
    } else {
        stage2img = "stage2.img";
    }

is run after:

            /* ok messy - see if we have a stage2 on local CD */
            /* before trying to pull one over network         */
            cdurl = findAnacondaCD(location, modInfo, modLoaded,
                                 *modDeps, 0);
            if (cdurl) {
                /* verify that our URL is specifying the correct tree */
                /* we do this by attempting to pull a .discinfo file */
Comment 1 Jerry Vonau 2007-12-16 18:48:23 EST
Created attachment 289738 [details]
patch to loader

Here is a patch to correct this issue. May not apply cleanly to current git
with all the recent changes but you should be able to migrate it. Not fully
tested with all types of installs but it does what I need it to do.
Comment 2 Jesse Keating 2008-01-15 16:10:21 EST
This doesn't seem to happen on 11.4.0.21.  I've tried both text and mem=126M
with rescue.iso and in both cases the local stage2 is used.
Comment 3 Jerry Vonau 2008-01-18 22:51:57 EST
Confirmed fixed with 11.4.0.21, thanks

Note You need to log in before you can comment on or make changes to this bug.