Bug 39763 - mpg123 ignores the -a command line option
mpg123 ignores the -a command line option
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mpg123 (Show other bugs)
7.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-08 22:09 EDT by Mike A. Harris
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-08 22:09:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2001-05-08 22:09:26 EDT
Description of Problem:
When using mpg123 to play mp3's at the console without X running, it
does not accept the "-a" commandline option as documented in the manpage.
It also forces the use of the esound daemon which IMHO is inherently
wrong.  It should not force the output device to anything.  Some people
may have esound running, others artsd, and others yet don't want to use
either daemon, but rather force the output device to a particular sound
card.  The proper fix is to rip the code out that forces the use of esound,
and replace it with code that *optionally* uses esound or artsd for sound
output while defaulting to the stock mpg123's behaviour.

I use mpg123 in scripts to notify me of build success/failure and tonnes
of other uses.  It only works sometimes and not others.  I tracked it down
to a conflict between esound and artsd, and other programs all trying to
do stuff simultaneoudly.  Rebuilding mpg123 stock without the esound stuff
fixes the problem.

How Reproducible:
100%

Steps to Reproduce:
1. Run KDE desktop, run xmms, and a few other apps like mixers, etc.
2. With out anything actually playing sound, try having a ssh sesssion
   from another machine ssh in and fire off mpg123.
3. Play around with other sound apps on the machine.  It sometimes will
   play an mp3, and other times will not.  Using /dev/dsp seems to always
   work.  (As long as nothing else is actually playing sound.)

Expected Results:
1) /dev/dsp is the default output device
2) If /dev/dsp is not accessible, perhaps then use esd or artsd
3) At all times honour the -a commandline option so I people can use
   mpg123 more flexibly instead of being locked into esound.  Especially
   useful for machines with multiple soundcards/dsp devices.
Comment 1 Bill Nottingham 2002-01-23 22:22:17 EST
Since we've since shipped to mpg321, this probably won't be fixed.

Note You need to log in before you can comment on or make changes to this bug.