Bug 397631 - drm:i915_vblank_swap *ERROR Invalid pipe 0
drm:i915_vblank_swap *ERROR Invalid pipe 0
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-24 00:30 EST by MASAO TAKAHASHI
Modified: 2008-03-01 00:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-01 00:00:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
cat /proc/dri/0/* (1.10 KB, text/plain)
2007-11-24 00:30 EST, MASAO TAKAHASHI
no flags Details
Xorg.0.log (22.14 KB, text/plain)
2007-11-27 03:14 EST, MASAO TAKAHASHI
no flags Details
configuration file (66.04 KB, application/octet-stream)
2007-11-27 18:15 EST, MASAO TAKAHASHI
no flags Details
dmesg log (17.05 KB, application/octet-stream)
2007-11-27 18:16 EST, MASAO TAKAHASHI
no flags Details
lsmod log (1.80 KB, text/plain)
2007-11-27 18:17 EST, MASAO TAKAHASHI
no flags Details
dmesg with verbose drm debug messages on linux-2.6.24-0.45.rc3.git1.fc9 (49.35 KB, application/octet-stream)
2007-11-27 20:08 EST, MASAO TAKAHASHI
no flags Details
more verbose drm debug messages (32.23 KB, application/octet-stream)
2007-12-04 02:02 EST, MASAO TAKAHASHI
no flags Details
more verbose X.org.0.log (19.43 KB, application/octet-stream)
2007-12-04 02:04 EST, MASAO TAKAHASHI
no flags Details
X.org.0.log (19.04 KB, application/octet-stream)
2008-01-08 19:48 EST, MASAO TAKAHASHI
no flags Details
X.org.0.log with 2.6.24-0.138.rc7.bz397631.fc9 (18.88 KB, application/octet-stream)
2008-01-09 19:01 EST, MASAO TAKAHASHI
no flags Details

  None (edit)
Description MASAO TAKAHASHI 2007-11-24 00:30:24 EST
Description of problem:
Invoking Googleearth, I got a error log in dmesg as belows.
 "[drm:i915_vblank_swap] *ERROR* Invalid pipe 0"

And driconf gives a message "Could not detect any configurable direct-rendering
capable devices. DRIconf will be started in expert mode."
But there exists /dev/dri/card0.

Chipset : intel 82865G

Version-Release number of selected component (if applicable):
googleearth-4.2.0198.2451 (beta)
How reproducible:

Steps to Reproduce:
1. To invoke googleearth or driconf
Actual results:

Expected results:

Additional info:
Comment 1 MASAO TAKAHASHI 2007-11-24 00:30:26 EST
Created attachment 267941 [details]
cat /proc/dri/0/*
Comment 2 MASAO TAKAHASHI 2007-11-27 03:14:44 EST
Created attachment 269511 [details]
Comment 3 MASAO TAKAHASHI 2007-11-27 03:16:26 EST
I have tested on linux-2.4.26-0.45.rc3.git1.fc9.
But, X server cannot recognize dri.
Xorg.0.log is attached
Comment 4 Kyle McMartin 2007-11-27 10:43:12 EST
Could you please attach a copy of your "dmesg" and "lsmod" so we can determine
if the correct modules are loaded?
Comment 5 MASAO TAKAHASHI 2007-11-27 18:14:37 EST
I generate kernel with config options such as  "CONFIG_DRM=y" and 
I tried to generate kernel with "CONFIG_DRM=m" and "CONFIG_DRM_I915=m".
But, I get a same result.
I attach dmesg and ".config" and a lsmod log 
Comment 6 MASAO TAKAHASHI 2007-11-27 18:15:35 EST
Created attachment 270581 [details]
configuration file

configuration file
Comment 7 MASAO TAKAHASHI 2007-11-27 18:16:34 EST
Created attachment 270591 [details]
dmesg log
Comment 8 MASAO TAKAHASHI 2007-11-27 18:17:14 EST
Created attachment 270601 [details]
lsmod log
Comment 9 MASAO TAKAHASHI 2007-11-27 20:08:09 EST
Created attachment 270641 [details]
dmesg with verbose drm debug messages on linux-2.6.24-0.45.rc3.git1.fc9
Comment 10 MASAO TAKAHASHI 2007-12-04 01:55:30 EST
(In reply to comment #4)
> Could you please attach a copy of your "dmesg" and "lsmod" so we can determine
> if the correct modules are loaded?
I attached already.
And Now, I tested linux-2.6.24-0.69.rc3.git7.fc9.
The "drm:i915_vblank_swap *ERROR Invalid pipe 0" error is still alive 
when invoking googleearth.
My hardware is as follows
 pentium 4 2.6GHz
 512MB memory
 8MB AGP memory
 82865G intel chip

Comment 11 MASAO TAKAHASHI 2007-12-04 02:02:21 EST
Created attachment 276591 [details]
more verbose drm debug messages
Comment 12 MASAO TAKAHASHI 2007-12-04 02:04:56 EST
Created attachment 276601 [details]
more verbose X.org.0.log
Comment 13 Kyle McMartin 2008-01-07 13:29:19 EST
Can you retry with the latest kernel in rawhide?
cheers, Kyle
Comment 14 MASAO TAKAHASHI 2008-01-08 19:44:10 EST
I retry with linux-2.6.24-0.138.rc7.fc9.
The error message does not appered.
But, "glxgear" is failed displaying following message.
"glxgears: intel_tris.c:114: intelStartInlinePrimitive: Assertion
`intel->batch->id == intel->last_state_batch_id' failed.

Perhaps, mesa library has problem.
I attach X.org.0.log .

Comment 15 MASAO TAKAHASHI 2008-01-08 19:48:05 EST
Created attachment 291107 [details]

with linux-2.6.24-0.138.rc7.fc9
Comment 16 Kyle McMartin 2008-01-09 10:39:31 EST
Please try the rpms at

they incorporate a possible fix.

cheers, Kyle
Comment 17 MASAO TAKAHASHI 2008-01-09 18:59:44 EST
Dear Mr. Kyle.
I tried with the package that you recommended above.
But, glxgears is failed with same error message.
And there are no warning messages in X.org.0.log such as
  (WW) intel(0): PRB0_CTL (0x0000f001) indicates ring buffer enabled
 (WW) intel(0): Existing errors found in hardware state.

Please see an attached log.
Comment 18 MASAO TAKAHASHI 2008-01-09 19:01:05 EST
Created attachment 291217 [details]
X.org.0.log with 2.6.24-0.138.rc7.bz397631.fc9
Comment 19 MASAO TAKAHASHI 2008-02-28 18:55:22 EST
I have tested again.
!. environment
2. results
   Google worked well.
   The error message was gone.
Comment 20 MASAO TAKAHASHI 2008-02-29 03:46:48 EST
I correct a mesa revision.
mesa-7.1-0.17.fc9 has a problem which can not enable dri.
mesa-7.1-0.16.fc9 is good.
Comment 21 MASAO TAKAHASHI 2008-03-01 00:00:41 EST
It seems that the problem is gone away.
I close this report.
The another problem concerned with mesa package.
The gcc option "-fvisibility=hidden" is restored again in mesa-7.1-0.17.
This option causes an undefined symbol error while loading "i915_dri.so".
 undefined symbol are "_glthread_xxx".
After generating mesa without "-fvisibility=hidden" options, the above error is not
 displayed and "dri" is enabled.

Note You need to log in before you can comment on or make changes to this bug.