Bug 397981 - docbook-utils causes build errors in gnome apps
docbook-utils causes build errors in gnome apps
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: docbook-dtds (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-24 14:05 EST by Kjartan Maraas
Modified: 2008-01-03 07:36 EST (History)
1 user (show)

See Also:
Fixed In Version: docbook-dtds-1.0-35.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 07:36:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2007-11-24 14:05:53 EST
Description of problem:

After updating to the latest release from rawhide I see errors. Backing down to
the previous release fixes it.

xsltproc -o mixer_applet2-es.omf --stringparam db2omf.basename mixer_applet2
--stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD
DocBook XML V4.1.2//EN" --stringparam db2omf.lang es --stringparam
db2omf.omf_dir "/opt/gnome2/share/omf" --stringparam db2omf.help_dir
"/opt/gnome2/share/gnome/help" --stringparam db2omf.omf_in
"/home/kmaraas/cvs/gnome/gnome-applets/mixer/docs/mixer_applet2.omf.in" 
--stringparam db2omf.scrollkeeper_cl "`scrollkeeper-config
--pkgdatadir`/Templates/C/scrollkeeper_cl.xml" `/usr/bin/pkg-config --variable
db2omf gnome-doc-utils` es/mixer_applet2.xml || { rm -f "mixer_applet2-es.omf";
exit 1; }
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:115: parser warning :
PEReference: %list.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:115: parser warning :
PEReference: %admon.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:115: parser warning :
PEReference: %linespecific.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:115: parser warning :
PEReference: %synop.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:115: parser warning :
PEReference: %para.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:115: parser warning :
PEReference: %informal.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:115: parser warning :
PEReference: %formal.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:115: parser warning :
PEReference: %compound.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:115: parser warning :
PEReference: %genobj.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:115: parser warning :
PEReference: %descobj.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:115: parser warning :
PEReference: %ndxterm.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:125: parser warning :
PEReference: %list.class; not found
                %local.refcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:125: parser warning :
PEReference: %admon.class; not found
                %local.refcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:125: parser warning :
PEReference: %linespecific.class; not found
                %local.refcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:125: parser warning :
PEReference: %synop.class; not found
                %local.refcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:125: parser warning :
PEReference: %para.class; not found
                %local.refcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:125: parser warning :
PEReference: %informal.class; not found
                %local.refcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:125: parser warning :
PEReference: %formal.class; not found
                %local.refcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:125: parser warning :
PEReference: %compound.class; not found
                %local.refcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:125: parser warning :
PEReference: %genobj.class; not found
                %local.refcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:125: parser warning :
PEReference: %descobj.class; not found
                %local.refcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:125: parser warning :
PEReference: %ndxterm.class; not found
                %local.refcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:135: parser warning :
PEReference: %linespecific.class; not found
                %local.indexdivcomponent.mix;">
                                              ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:135: parser warning :
PEReference: %synop.class; not found
                %local.indexdivcomponent.mix;">
                                              ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:135: parser warning :
PEReference: %para.class; not found
                %local.indexdivcomponent.mix;">
                                              ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:135: parser warning :
PEReference: %informal.class; not found
                %local.indexdivcomponent.mix;">
                                              ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:135: parser warning :
PEReference: %link.char.class; not found
                %local.indexdivcomponent.mix;">
                                              ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:141: parser warning :
PEReference: %tech.char.class; not found
                %local.refname.char.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:156: parser warning :
PEReference: %xref.char.class; not found
                %local.refinline.char.mix;">
                                           ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:156: parser warning :
PEReference: %gen.char.class; not found
                %local.refinline.char.mix;">
                                           ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:156: parser warning :
PEReference: %link.char.class; not found
                %local.refinline.char.mix;">
                                           ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:156: parser warning :
PEReference: %tech.char.class; not found
                %local.refinline.char.mix;">
                                           ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:156: parser warning :
PEReference: %base.char.class; not found
                %local.refinline.char.mix;">
                                           ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:156: parser warning :
PEReference: %docinfo.char.class; not found
                %local.refinline.char.mix;">
                                           ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:156: parser warning :
PEReference: %other.char.class; not found
                %local.refinline.char.mix;">
                                           ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:156: parser warning :
PEReference: %ndxterm.class; not found
                %local.refinline.char.mix;">
                                           ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:204: parser warning :
PEReference: %role.attrib; not found
<!ENTITY % set.role.attrib "%role.attrib;">
                                          ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:219: parser warning :
PEReference: %status.attrib; not found
                %status.attrib;
                               ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:220: parser warning :
PEReference: %common.attrib; not found
                %common.attrib;
                               ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:230: parser warning :
PEReference: %role.attrib; not found
<!ENTITY % setinfo.role.attrib "%role.attrib;">
                                              ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:236: parser warning :
PEReference: %bibliocomponent.mix; not found
        | keywordset | itermset | %bibliocomponent.mix;)+)>
                                                       ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:236: parser error :
ContentDecl : Name or '(' expected
        | keywordset | itermset | %bibliocomponent.mix;)+)>
                                                       ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:236: parser error :
expected '>'
        | keywordset | itermset | %bibliocomponent.mix;)+)>
                                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:236: parser error :
Content error in the external subset
        | keywordset | itermset | %bibliocomponent.mix;)+)>
                                                         ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:243: parser warning :
PEReference: %setinfo.attlist; not found
<![%setinfo.attlist;[
                    ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:243: parser error :
conditional section INCLUDE or IGNORE keyword expected
<![%setinfo.attlist;[
                    ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:243: parser error :
Content error in the external subset
<!ATTLIST setinfo
 ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:243: parser error :
Content error in the external subset
<!ATTLIST setinfo
    ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:243: parser error :
Content error in the external subset
<!ATTLIST setinfo
       ^
unable to parse es/mixer_applet2.xml

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ondrej Vasik 2007-11-26 05:06:26 EST
Thanks for report, is likely that it was caused by typo in docbook-dtds spec
(#397651), but I want to be sure. 
Please provide 'rpm -q docbook-utils' and 'rpm -q docbook-dtds' in correct
running and error-causing environment - if possible. 

Latest version in rawhide is 0.6.14-13 and changes between 0.6.14-13 and
previous 0.6.14-12 were not in area which could cause problem you described.
Comment 2 Kjartan Maraas 2007-11-26 06:32:31 EST
Working:

[kmaraas@localhost ~]$ rpm -q docbook-dtds docbook-utils
docbook-dtds-1.0-34.fc9
docbook-utils-0.6.14-12.fc9

Not working:
same but with the latest docbook-utils (0.6.14-12.fc9). So the only thing I
changed to get it working was to go back one revision with docbook-utils...
Comment 3 Ondrej Vasik 2007-11-26 07:33:30 EST
Sorry - I'm a bit confused by your version report. Not working with
0.6.14-12.fc9 and working with 0.6.14-12.fc9. Maybe I missed something...

As I said - the only change between 0.6.14-12.fc9 and 0.6.14-13.fc9 version was
a patch to txt backend when using w3m text web browser for conversion. This is
obviously not your case.

Anyway docbook-dtds-1.0-34.fc9 was buggy (wrong registration of docbook
catalogs) and I made docbook-dtds-1.0-35.fc9 today which should fix the problem.
As I said - I suspect that thing as source of troubles. 

Please clarify the version info. Which package are you trying to build? I would
like to try to reproduce it on my machine(if not in redhat cvs, please provide
the link). If not possible to provide link/package name, try to reproduce with
docbook-dtds-1.0.35.fc9 and docbook-utils-0.6.14.13.fc9. Thanks.
Comment 4 Kjartan Maraas 2007-11-26 11:26:30 EST
That was just a small typo. Not working was -13. Anyway. I'll try the next batch
of updates from rawhide on a new jhbuild of GNOME and see what happens.
Comment 5 Kjartan Maraas 2008-01-03 07:08:47 EST
I think you can close this now. Haven't seen this in a while.
Comment 6 Ondrej Vasik 2008-01-03 07:36:13 EST
Ok, changing component to docbook-dtds and closing as current release - as the
problem was most probably caused by buggy docbook-dtds-1.0-34.fc9 (#397651) .
.

Note You need to log in before you can comment on or make changes to this bug.