Bug 398021 - Evolution doesn't load online images from email
Evolution doesn't load online images from email
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-24 15:44 EST by Jorrit
Modified: 2008-06-17 07:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-17 07:58:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
newsletter without loading images (50.98 KB, application/octet-stream)
2008-03-13 18:17 EDT, Jorrit
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 340838 None None None Never

  None (edit)
Description Jorrit 2007-11-24 15:44:07 EST
Description of problem:
Newsletters with images online do not load even after pressing ctrl-i and having
the senders address in the address book.
Needs saying I've only tested it with imap accounts, but doubt that is the cause.

Version-Release number of selected component (if applicable): 2.12.1


How reproducible:
Always, also using a clean profile

Steps to Reproduce:
1. Start Evolution mail client
2. Open newsletter
3. No images loaded
4. press ctrl-i 
5. No images loaded
  
Actual results:


Expected results:
Too shiny emails

Additional info:
Comment 1 Matthew Barnes 2007-11-25 17:54:02 EST
What option do you have selected under
Edit -> Preferences -> Mail -> HTML Messages -> Loading Images?
Comment 2 Jorrit 2007-11-27 15:55:10 EST
In my preferences it says something like (my session is in Dutch) "Load images
when sender is in address book"
Comment 3 Matthew Barnes 2007-11-27 16:57:15 EST
Is the sender of the newsletters you're receiving in your address book?  Does
changing the preference to "Always load images from the Internet" help?

I'm not sure if Ctrl-I is meant to override this preference.  Seems like it
should...
Comment 4 Jorrit 2007-11-27 17:04:21 EST
Sender is in address book, and also changing it to always load images from
internet does not change the behaviour.
Another note by the way, it seems that it is downloading the images, but just
doesn't display them.
Comment 5 Matthew Barnes 2008-03-11 23:37:25 EDT
Can you post a sample newsletter with missing images?
Comment 6 Jorrit 2008-03-13 18:17:07 EDT
Created attachment 297995 [details]
newsletter without loading images
Comment 7 Jorrit 2008-03-13 18:20:14 EDT
Clean profile, fresh fedora 8 install, still not the expected result, however it
looks like after ctrl-i one image gets displayed this time, but still not all.
Comment 8 Milan Crha 2008-06-17 07:58:35 EDT
I looked into the source of the message and even it contains some pictures which
are not available anymore
http://www.computable.nl/media/grad_1.gif
http://www.computable.nl/media/grad_4.gif
http://www.computable.nl/media/grad_5.gif
http://www.computable.nl/media/pijl_left_darkblue.gif
http://www.computable.nl/media/grad_bg_2.gif
http://www.computable.nl/media/pijl_mid_loopbaan.gif
http://www.computable.nl/media/pijl_mid_darkblue.gif

then most of them are still there, but not shown in evolution.

http://vedm.net/open2.gif?m=hIXp&s=gXErS3
http://www.computable.nl/mailing/media/i.gif
http://www.computable.nl/mailing/media/bg_shadow_top.gif
http://www.computable.nl/mailing/media/logo_computable.gif
http://www2.vnunet.nl/nb_ads_src/1202731592_20070320-Trends-in-IM-468x60.gif
http://www.computable.nl/mailing/media/home.gif
http://www.computable.nl/pcit/img.db?2271570
http://www.computable.nl/pcit/img.db?2237047
http://www.computable.nl/pcit/img.db?2260869
http://www.computable.nl/pcit/img.db?2324882
http://www.computable.nl/pcit/img.db?2389628
http://www.computable.nl/pcit/img.db?2389014
http://www.computable.nl/pcit/img.db?2389050
http://www.computable.nl/pcit/img.db?2060978
http://www.computable.nl/pcit/img.db?2388669
http://www.computable.nl/pcit/img.db?2227160
http://www.computable.nl/pcit/img.db?2389013
http://www.computable.nl/pcit/img.db?2388670
http://www.computable.nl/pcit/img.db?2388671
http://www.computable.nl/pcit/img.db?2248529
http://www.computable.nl/pcit/img.db?2195803
http://www.computable.nl/pcit/img.db?2388673
http://www.computable.nl/pcit/img.db?2388672
http://www.computable.nl/pcit/img.db?2388674
http://www.computable.nl/mailing/media/zoek3.gif
http://www.computable.nl/mailing/media/bullet.gif
http://www.computable.nl/pcit/img.db?2381725
http://www.computable.nl/pcit/img.db?2356774
http://www.computable.nl/pcit/img.db?2356521
http://www.computable.nl/pcit/img.db?2078700
http://www.computable.nl/mailing/media/verteldoor.jpg

I guess it has something to do with the url, but I would like to move it
upstream and solve the issue with them. Thanks for your help.

The upstream bug [1] seems to be the same as this.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=340838

Note You need to log in before you can comment on or make changes to this bug.